Skip to Content
avatar image
Former Member

Unable to apply SAP_APPL patch(es)

I’m unable to apply SAP_APPL patch(es) - SAPKH60001-SAPKH60004

I can apply other patches no problem; but cannot apply SAP_APPL patch

SAPKH60001.

When applying the patch I see "tp user check OK" but will just hang at

this stage (little clock spinning away for hours). Status of import

says "Error in phase: DISASSEMBLE” but no error codes.

Steps for the Reconstruction

1. Updated kernel, update SPAM/SAINT and applied SAP_BASIS, SAP_ABA,

SAP_BW and PI_BASIS Patches.

2. Attempt to update SAP_APPL patch(es) but SPAM hangs "tp user check

OK" but will just hang at this stage (little clock spinning away for

hours). Status of import says "Error in phase: DISASSEMBLE” but no

error codes.

3. So I deleted files in usr\sap\trans\EP\in, deleted associated data

and cofiles for SAPKH60001 ran SPAM again to read all files in EPS/in

(this is now empty, so reset). , and downloaded the latest version of

the patch, unpacked, and re-read the files in SPAM.

4. Defined queue for SAPKH60001 (just this one patch to see how it

would go w/ just one patch) and import again and get the same result.

At the OS level (Windows) I see SPAM re-create the data file but it

does not create the cofile.

5. I stopped the import of SAP_APPL then tried to see if I could import

a different patch... I was able to update ST-PI. So seems specific to

this patch.

Environment:

SAP ECC 6.0 Windows/SQL

Any help or suggestion much appreciated!

Regards,

-Patrick

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Best Answer
    avatar image
    Former Member
    Jul 07, 2006 at 05:45 PM

    check the following logs

    1) Action log in SPAM

    2) Tp alog and slog

    3) Sm21 /st22

    if you do not find and error message in these,

    check sm66 for the process doing the dissambeling work. if it is a dialog porcess check whether it is getting timed out

    let me know

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 07, 2006 at 06:57 PM

    Patrick,

    Try to download and extract the support pack to EPS/in again. Then try to re-import. Make sure you have enough space in /usr/sap/trans.

    Neval

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 19, 2006 at 02:16 PM

    Hi Patrick:

    Have you tried skipping this particular support pack and tried to implement a different support pack (something that met all the prerequisites).

    The reason i suggest this is to figure out if the issue is with the support pack in question or with the system.

    I also suggest that you restart the entire system (if possible)

    Hopefully this helps.

    Imran Khan

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 19, 2006 at 02:42 PM

    Hello Patrick,

    Please check OSS note 822379 for this issue. I hope it might be of some help for you.

    With Regards.

    Ruchit.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 30, 2006 at 08:24 PM

    Thanks for replies! SAP came back on this and helped me to solve...

    SAP Note 690449 is the one that did the trick.

    You have an warning as

    WARNING:
    sapsolmgr\sapmnt\trans\tmp\SAPKKH60001.QAS is already in us (115000), I'm waiting 5 sec (20060710110328).

    - 12746 WARN <file> is already in use (), I'm waiting 5 sec

    - 690449 Transport buffer lock file (.LOB) remains blocked on Windows

    I hope this helps.

    Add comment
    10|10000 characters needed characters exceeded