Skip to Content
avatar image
Former Member

sap.viz.libs.sap-common-globalization in SDK Design Studio 1.6 SP4

Hello Experts,

I have been created DS add-on in SDK Design Studio 1.6 SP2. I did test with DS 1.6. SP4 and noticed 1 problem.

My component is based on DIV (no D3, no SAPUI5 etc.), but I need to format numbers, so I do it using functions/methods from "sap.common.globalization.NumericFormatManager".

To have these function available I load library using below command:

jQuery.sap.require("sap.viz.libs.sap-common-globalization");

In 1.6 SP2 works correctly, in SP4 not, I receive error message that is not possible to load JS file:

Error: failed to load 'sap/viz/libs/sap-common-globalization.js' from resources/~20160527141328~/sap/viz/libs/sap-common-globalization.js

How to handle it correctly?

I checked that I don't need to load "sap-common-globalization" manually when I add CVOM as stdInclude, but to be honest I don't need whole CVOM library, so it's only "ugly" workaround.

How should I handle it correctly?
Thanks in advance.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

0 Answers