Skip to Content
0

Master view of SplitApp is not hiding properly after changing its width through css

Mar 06, 2017 at 01:52 PM

56

avatar image

After changing the width of Master panel of SplitApp . It is not collapsing or hiding the panel properly.
I used css to change the width of master panel.

.wrapperShell .sapMSplitContainerMaster {
width:35%

}

included this class inside onInit function of controller

oSplitApp.addStyleClass("wrapperShell");

Below is the image showing how it is hiding the master in landscape orientation.

After hiding

zth24.png (11.6 kB)
agjfp.png (8.9 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Gowrinath Gundu Mar 06, 2017 at 09:32 PM
0

Hi Vaibhav,

Rather than applying css, you can create a button on screen and on press of this event, you can set mode parameter of splitapp container

Regards,

Gowrinath

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi Gowrinath,

Thanks for the reply.
I am using css to change the width of master panel not for hiding it. For hiding I am using set mode method . But problem is that , it is not hiding properly as shown in the image.

Thanks
Vaibhav

0

Hi Vaibhav,

You can reduce the width of the controls in master page. I believe they are right now at 100% and hence your master page is occupying more space. Set the width to 50% for all the controls in master page. Alternatively, apply css to controls in master page rather than to the app.

Hope this solution helpful for you

Regards,

Gowrinath

0
Siddharth Rao
Mar 07, 2017 at 09:43 AM
0

Hi there,

I agree with Gowrinath in that using custom CSS to bring about this effect may not be the best idea.

Have a look at the enumeration: sap.m.SplitAppMode for your needs.

Share
10 |10000 characters needed characters left characters exceeded