Skip to Content
avatar image
Former Member

problem in connecting JCO destination in web dynpro

HI all,

I was installed sneak preview of Net weaver 6.4,

I want to do some web dynpro (java) programs which connect to back end systems.(R/3 system).

The R/3 system which I want to connect is at remote place, i have connectivity to that R/3 system using VPN connectivity. With this I am not having any problem. Since I am able to connect using User name and password, and able to do some transactions like RZ70, etc.

I developed an application which calls COMPANY_CODE_GET_LIST (BAPI function).

for the above requirement what I did was

(1)I created SLD setting.

(a)Web as Java (I am not having any problem to

Create this.

(b) Web as ABAP.

When i am trying to create

This, there are some steps like i need to go to SAP log in and I need to run the transaction RZ70. For this i need to create an enter in visual administrator >JCO RFC Provider >runtime-->Bundles i need to create an entry for RFC destination as well as Repository.

under RFC destination there are some fields which i need to enter those are (a)Program ID as mySLD (b) Gateway Host as 10.10.10.125 (c)Gateway service as sapgw00 (d)Number of processes as 1

Under Repository (a) Application server host 10.10.10.125 (b)system number as 00 (c)Client number as 100 (d)Language as en (e)user as ABCD (f)password as 1234

I haven't choused the check boxes Local bundle and Unicode and pressed the set button. So like this i created the RFC destinations. under the properties tab there is a property called RFC_DEFAULT_DESTINATION by default it was false so i made it as true. .

I also went to SLD Data Supplier,under Runtime tab , HTTP Settings , I mentioned

(a)Host: pava-vis75

(b) Port: 50000

(c) user: administrator

(d) password: abcd1234

RFC Settings, I mentioned as

(a)Gateway Host: 10.10.10.125 (which is SAP R/3 system)

(b)Gateway Service/Host: sapgw00

CIM Client Generation settings, as

(a)Host: pava-vis75

(b)Port (http/https):50000

(c) user: administrator

(d) Password : abcd1234

I tested the CIMClient Test by click the the button. I got the successful message.

Then I came back to HTTP settings and clicked the button with tilted arrow mark [This triggers data transfer to system landscape directory], for this also I got a successfully message.[data transferred successfully]

Next I been to SAPLOGON and went to RFC Destinations by using sm59 transaction. There under TCP/IP connections i been to SLD_NUC , opened this by double clicking that and under Technical settings for Program ID I had given the ID which I created at visual administrator [JCO RFC Provider] which is mySLD , under gateway options for Gateway Host as 10.10.10.125and Gateway service as sapgw00 then i tested the connection, it was also successfully.

Then I opened the SLDAPICUST and i created a new entry for maintaining the SLD Access Data by giving some couple of entries as

(a)Alias: vissldtest

(b)Host Name: pava-vis75

(c)Port: 50000

(d) user: administrator

(e) password: abcd1234

Then saved it.

Next I created sapmsUV0 3600/tcp entry at

WINDOWS\system32\drivers\etc\services file, and also there are some required entries which are already existing those are sapgw00 3300/tcp to sapgw99 3399/tcp , another entry starts from sapdp00s 4700/tcp to sapdp99s 4799/tcp , next entry starts from sapgw00s 4800/tcp to sapgw99s 4899/tcp and sapmsJ2E 3601/tcp .

I restarted the system, as well as server.

Now my problem is when I was trying to create JCO destination at web dynpro content administrator. For that I navigated as “create JCO Destination Deployed Contentlocal-local/CompanyCodeGetList-Applications CompanyCodeGetList

I Choosed the JCO Connections tab- there are 2 entries those are

(1) COMPANY_CODE_MODEL

(2) COMPANY_CODE_RFC_METADATA

So I started creating connection for COMPANY_CODE_RFC_METADATA.

First one is

General data Name : COMPANY_CODE_RFC_METADATA

Client : 100

I didn’t changed any default JCo pool configuration.

J2EE Cluster

There is a check box called “Use Local J2EE engine J2E on pava-vis75’ so I choosed that.

Connection Type

Dictionary Meta Data and application Data

I choosed the first one.

Then

Msg. Server Connection

Security

After these, I tried to test the connection by clicking the ‘Test Connection.

It is saying the error as

First time

com.sap.mw.jco.JCO$Exception: (102) RFC_ERROR_COMMUNICATION: Connect to message server host failed Connect_PM TYPE=B MSHOST=v011 GROUP=DEFAULT R3NAME=UV0 MSSERV=sapmsUV0 PCS=1 ERROR service 'sapmsUVO' unknown TIME Fri Jul 01 07:20:41 2006 RELEASE 640 COMPONENT NI (network interface) VERSION 37 RC -3 COUNTER 1

second time

com.sap.mw.jco.JCO$Exception: (102) RFC_ERROR_COMMUNICATION: Connect to message server host failed Connect_PM TYPE=B MSHOST=v011 GROUP=DEFAULT R3NAME=UV0 MSSERV=sapmsUV0 PCS=1 ERROR service '?' unknown TIME Fri Jul 01 07:20:41 2006 RELEASE 640 COMPONENT NI (network interface) VERSION 37 RC -3 COUNTER 1

Can any body please help me to solve this problem.

From past 1 week on wards I have been trying to resolve this. But in vain.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Jul 05, 2006 at 05:27 AM

    this is because of the logon group issue.

    check this weblog - particularly the last paragraph (sub heading <b>The Message Server</b>. i had the same problem and doing the steps explained in the last paragrpah of this weblog, helped me to solve it

    /people/thomas.jung/blog/2006/02/08/as-abap-sneak-preview-lessons-logon-groups

    Regards

    Raja

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      It does not necessarily mean that you have to change that parameter. I read that blog as I had a similar problem, and after reading it and understanding the reasons and possible causes for the error, I found that my particular problem was that I was using "PUBLIC" as the logon group in my JCO destinations, but such a group does NOT exist at my backend. I went to transaction SMLG, had a look at Logon Groups, noted that there were none other than SPACE, figured out that I had to include that information in SLD (Web AS ABAP tech. system --> Message Server --> Logon Groups), put it there. Voilá. It works.

      Edit: That SPACE logon group is the one I had to use at JCO destinations. Sorry I forgot to mention that one...

      Regards,

      Eduardo.

      Message was edited by: Jesus Cil