Skip to Content
0
Former Member
Jul 04, 2006 at 05:28 AM

Problems with JCo

16 Views

hi,

i wrote a standlone java client that uses Jco to connect to SAP . it worked fine till recently.But now its giving a

Exception

java.lang.ExceptionInInitializerError: JCO.classInitialize(): Could not load middleware layer 'com.sap.mw.jco.rfc.MiddlewareRFC'

JCO.nativeInit(): Could not initialize dynamic link library librfc. <b>Found version "620.0.1844" but required at least version "640.0.76"</b>.

at com.sap.mw.jco.JCO.<clinit>(JCO.java:738)

at com.pass.Connect.main(Connect.java:25)

Exception in thread "main" .

i can see that its some version confilct but how did it work till now. i didnt change any of the two dll's or the sapjar jar file

regards,

guru