Skip to Content
author's profile photo Former Member
Former Member

Installing ecc50 system, first time I've seen this error

Hi,

I am in the process of installing a ecc 5.0 system and recieve the

following errors:

ERROR 2006-06-28 18:02:17

MOS-01220 Missing file 'C:\WINDOWS\system32\SAPMMC.DLL'.

Copy the file manually.

ERROR 2006-06-28 18:02:17

MOS-01234 The specified procedure could not be found.

!

Error in execution of a 'LoadLibrary' function, line (221),

with parameter(s) (C:\WINDOWS\system32\SAPMMC.DLL).

ERROR 2006-06-28 18:02:17

MOS-01218 Unable to register SAP snap-in in the MMC.

I can see SAPMMC.DLL is in the c:\windows\system32 directory

Searched notes, sdm and even google and tried a number of things.

Uninstalling and reinstalling using regsrv32 but this did not work.

Just a point you should know is that previously on this server there was an SAP NetWeaver 2004s system installed on this system and the SAPMMC registered fine.

The NetWeaver 2004s system was completley uninstalled including uninstalling the database.

Have have renamed the original sapmmc.dll that was there, copied the one over from the installation and rebooted the server. None of this worked.

You can not get access to this system because I am onsite at a customer location. Please provide me with your suggestions.

I've done about 6 or 7 other ERP2004 installations and have never gotten this error before.

Thanks

Jerry

Thanks

Jerry

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Jun 29, 2006 at 04:51 AM

    Jerry Can it be a corrupted profile or some rights issue.

    Tryt creating a different admin account and install.

    I have seen this during installation of some sw that even some users who are admin cannot access some keys in Hive

    George

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      I figured out what I needed to do. I found a fair amount of notes that said if you have a problem with the sapmmc.dll you should run regsvr32 to either install the dll or /u to uninstall everytime I tried this with sapmmc.dll that was in windows or copied the one over from the installation directory when I ran either with or without the option I would get a popup saying "The specified library could not be found." I kept on searching and came across note 855830 ERP 2005 Installation on Windows, in the note it says after deleteing an sap system you need to run "regsvr32 /u sapmmc.dll". I hadn't looked at this note before because I was installing an erp2004(ecc50) system. But the note got me thinking we had previously done ECC60 and Netweaver 2004s installations on this server and deleted them but I don't think anyone ever ran the command above. But the dll I needed was no longer on the system. I ended up logging on to another ecc60 system we have, copied the sapmmc.dll over to the server I was working on. Ran regsvr32 /u, no errors uninstalled successfully, restarted the ecc50 central instance installation. Install ran fine

  • author's profile photo Former Member
    Former Member
    Posted on Nov 22, 2007 at 02:34 AM

    I had the same problem when installing netweaver 04 on sql server 2000 - you have to manually unpack archive sapmmc.sar from install master folder > nt > sapmmc

    IM_WINDOWS_I386/SAPINST/NT/I386/MMC/SAPMMC.SAR

    extract using sapcar that is also found in the folders, try search for sapcar in the whole downloaded folders, and place the sapcar and the sapmmc.sar to one folder and issue sapcar -xvf sapmmc.sar, all the files would be extracted and copy those files to the system32, it asks for rewrite say yes and press retry.

    and copy to windows\system32 folder Then retry installation.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Nov 23, 2007 at 03:50 PM

    Hi Jerry,

    This is a documented problem.

    To solve the problem, download the 710 SAP MMC MSI installation package from SAP Service Marketplace at: http://service.sap.com/swdc and install the 7.10 SAP MMC and other DLLs. The 7.10 MMC and DLLs are downward-compatible to the 7.00 and 6.40 kernels. Continue with the installation of your SAP product.

    Problem is documented in the following SAP Note:

    Note 967124 - 6.20/6.40 Patch Collection Installation: Windows

    Hope that helps.

    PS: Please close the question if its been answered.

    Regards,

    Siddhesh

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.