Skip to Content
0

SPED Not Triggering from iDoc Delivery PGI

Mar 03, 2017 at 12:20 PM

335

avatar image
Former Member

Hi Experts,

I am having an issue with inbound delivery creation using the standard SPED output. The outbound delivery is picked and PGI'ed via a 3PL iDoc (SHPCON-DELVRY03), but the SPED will not trigger automatically.

When you manually enter the outbound delivery the SPED output exists but not triggered (yellow traffic light) meaning the inbound delivery is not created. I have tried the both 3 send with application and 4 send immediately on the output type. If the trigger is set at 4 and the outbound delivery is saved manually the SPED output is triggered and the inbound delivery is created, so there are no problems triggering the SPED manually.

I am using standard SPED requirement 408 and no enhancements have been added.

Any ideas why the SPED will not trigger automatically. I need it to be triggered without human intervention.

Thanks in advance.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

avatar image
Former Member
Mar 03, 2017 at 01:28 PM
1

Hello,

Could you please refer this note "1119073 - FAQ: Automatic inbound delivery creation for stock transfers"

Especially note "965176 - Creation of inbound delivery during two-step stock transfers" which has the details about the SPED settings and it's already part of above note under question 5.

Thanks,
Balaji

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Mar 03, 2017 at 01:48 PM
0

Thanks for the reply. I have already viewed these notes and everything is setup correctly.

The SPED functionality works fine when triggered manually by saving the delivery but I need it to trigger in the background once the iDoc has posted the goods issue.

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Mar 09, 2017 at 07:37 PM
0

I have finally found the resolution to the problem by debugging the code.

Transaction VL10CUC - there is a flag set for delivery creation, table T186 to allow output determination. This flag was set thus the code ignored the output determination procedure.

Share
10 |10000 characters needed characters left characters exceeded