Skip to Content
author's profile photo Former Member
Former Member

Visual Administrator - SLD DataSupplier write socket error

Hello,

I have install SAP Solution Manager 4.0 and am trying to test the Http://host:port/SLD connection. I can successfully login as the J2EE_ADMIN but the administration tab does not show as selectable and all the documentation we have come across is advising us we need to get into the Administration area to configure the SLD.

We have tried to assign the LcrAdministrator role to the user and assign SAP_SLD_ADMINISTRATOR on the ABAP end as well but still had no luck.

Add comment
10|10000 characters needed characters exceeded

1 Answer

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jul 11, 2006 at 02:00 PM

    Hi,

    Here is the complete SLD configuration steps:

    http://<host>:<port>/sld. say http://localhost:50200/sld

    Enter user name and password, and then choose OK.

    Give some valid name like "J2E" as object server.

    Go to administration link on top, there click on the button to start the server. The server must be running.

    Click on the import link, and in that page click on ‘Import CR content from the server’ button. It will import all required CR components in the list. (OR) alternatively, browse to the
    <server>\usr\sap\<SAPSID>\SYS\global\sld\model\

    Import first Cimsap.zip and cr_content.zip (MS Windows) and then choose Open. It will take 10 to 15 minutes to complete.

    Open Visual Administrator. Choose "SLD data supplier" service under Server-> services node.

    Go to HTTP Settings, enter the following

    Host : localhost

    Port : 50000

    User :

    Password :

    Go to CIM Client Generation Settings on same window

    Enter the following

    Host : localhost

    Port : 50000

    User :

    Password :

    After Saving the details click on “CIMClient Test”

    A pop-up screen shows “CIMOMClient object generation and connection test successful”. Click “Ok”. Now SLD is configured.

    Regards,

    Srinivasan T

    <b>Helpful answers=>POINTS</b>

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      I have the same problem and can not find a solution for two weeks.

      How did you assign correct role to J2EE_ADMIN user.I mean which role did you assign?

      I logon UME with J2EE_ADMIN user but it says you are not authorized to access this application.

      As far as I know I should assign roles with UME.

      And unfortunately I have even no rights to configure J2EE_ADMIN roles.

      Can you help me at this point?