Skip to Content

SAP CRM Web service tool transport

Hi All

I created a webservice using the webservice tool in the servicepro role in crm.

This service is created as a local object in the package $WS_BOL_GEN.

Can anyone tell me how do I transport this webservice to CRQ ?

I followed link spro>crm>ui framework>ui framework definition>web services>Web Services Tool to transport web service through WB, web service trasnported but status is inactive, only customization entries got created.

I can not see any package $WS_BOL_GEN in test system. There is no object related to web service structures, function groups, functions modules. There is no entry in web service related table e.g. srt_registry/ srt_registryt/ srt_reg_operat/ srt_reg_bind/ srt_reg_config.

I even cannot see web service in SICF transaction/ WSCONFIG/ WSADMIN/ SOAMANAGER.

I also checked SAP Note: 1300943/ 1437354/ 1639199/ 1821054 but did not get clear picture.

Can you please provide me step how to import web service from dev to test to prd.

Thanks

Kapil Anand

Add comment
10|10000 characters needed characters exceeded

2 Answers

  • Posted on Mar 03, 2017 at 01:42 PM

    Hi Anand,

    your issue about the missing package $WS_BOL_GEN are described in the note

    1418715 Paket $WS_BOL_GEN fehlt nach Upgrade

    As mentioned in the note the report Report CRMOST_CREATE_PAC created the missing package $WS_BOL_GEN.

    Best Regards

    Gerhard

    Add comment
    10|10000 characters needed characters exceeded

  • Posted on Aug 29, 2019 at 06:12 PM

    Hi Anand,

    Was your issue resolved by running the report "CRMOST_CREATE_PACKAGE" in QA system and then production system?. I see when you run the report the package gets created. Does the development object gets tied to the package immediately?. DId you run the report before or after import of the transports?.

    too many questions, apprciate your answer.

    Add comment
    10|10000 characters needed characters exceeded