Skip to Content
0

SAP PI 7.5 Axis Framework related jars

Mar 03, 2017 at 04:22 AM

237

avatar image
Former Member

Hello Experts,

I have Axis Framework installed on PI 7.4 and it is working fine there. Now, plan is to upgrade PI to 7.5. I would like to know if AXIS related jars can/should also be upgraded, more specifically, I am interested in wss4j version. There is ordering issue with 'wsse security header' elements which was fixed in 1.5.8 of wss4j:

https://issues.apache.org/jira/browse/WSS-147

SAP Note https://launchpad.support.sap.com/#/notes/0001776179 suggests that verified versions of wss4j are 1.5.4, 1.5.5, 1.5.6 & 1.5.7.

There are other jars as well (xerces, commons, opensaml, Sandesha, wsdl4j, etc). Like SAP Note 1776179, is there any other SAP note which clarifies which combination of these jars are verified and valid for SAP PI 7.5

Thanks,

Ankit

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

avatar image
Former Member Mar 28, 2017 at 02:51 PM
0

Hi Ankit,

I have exactly the same question. Did you got an SAP Note ?

Regards,

Erik

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Apr 19, 2017 at 07:31 AM
0

Hello Erik,

Sorry for a late response but following it up with SAP.

No concrete answer yet. I will update this place with the findings.

Thanks,

Ankit

Share
10 |10000 characters needed characters left characters exceeded
Helmut Skolaut Apr 21, 2017 at 07:11 PM
0

Hi all,

I have used the JAR file I have created for PI 7.1 and this JAR file I could have used w/o problems also in PI 7.5

Regards

Helmut

Share
10 |10000 characters needed characters left characters exceeded