Skip to Content
0

Regenerate ABAP data flows when upgrading Data services to 4.2

Mar 02, 2017 at 10:22 PM

25

avatar image

We are upgrading from 4.1 sp2 data services to 4.2 sp8. In the upgrade documentation, it states to regenerate the ABAP data flows but in the SAP supplement guide that the documentation states for more information, states something else.

in section 1.3.1 of the guide, it states

If you select Execute Preloaded for the ABAP execution option mode in your SAP Applications datastore, when Data Services executes a job that contains an ABAP data flow, it runs the previously generated and uploaded ABAP program. If this program was generated by an old version of Data Services, the job might not be taking advantage of the performance improvements in the latest version. You can set Data Services to trigger version warning messages when a job executes. If you find a version mismatch, upgrade the generated ABAP program on the SAP server to match the Data Services version.

So it states that it will run the old program. We actually have started to test running the 4.1 generated programs in the 4.2 environment and they do run. We do get the version mismatch.

Just wondering if others have left regenerating older programs after an upgrade or they absolutely had to regenerate to avoid issues.

Regards

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

0 Answers