Skip to Content
author's profile photo Former Member
Former Member

SAP J2EE Migration Plug-In

Hi,

We are using SAP J2EE Migration Plug-In to migrate from WebSphere to SAP NetWeaver Application Server.

According to the pdf file that comes with the Plug-In, the Plug-In will automatically detect the module.

But this is not happening when we tried.

Please let us know how to use this Plug-In.

Any kind of help will be greatly appreciated.

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Best Answer
    Posted on Jun 26, 2006 at 05:19 AM

    Hi,

    Though this pdf says that it determines the modules, but actually it doesnot.

    You need to manually create web/EJB modules. The selection of server will help in transformation of various server specific configuration xmls to run on SAP WAS.

    Do refer to code changes properly as mentioned in that pdf.

    Also, you need to put ejbCreate() empty method in your message/session beans too. As though this pdf does not talk about this, but you have to do it for all kind of EJBs.(Entity/session/message).

    Hope this info feeds good.

    Regards,

    Daman.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Damandeep Thakur

      1. First of all it looks like a typo in your xsd declaration:

      xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee  ejb-jar_2_1.xsd"

      Of course, you should replace the two blanks by one slash.

      2. Does your ejb-jar.xml verify outside the NetWeaver?

      3. NetWeaver 6.40 support J2EE 1.3, i.e. EJB 2.0. EJB 2.1 comes with J2EE 1.4 and will be supported by the future NetWeaver 7.x. Maybe this is the problem?

      4. The code snippet you show does not need EJB 2.1.

  • author's profile photo Former Member
    Former Member
    Posted on Jan 29, 2007 at 10:36 AM

    hi,

    I am facing some problems in using the migration kit for porting a j2ee project to NWDS. we are using NWDS 2004s SP10. Is the migration kit utility available in this version? I've copied all the pluggins to the relevant places, but the utility doesn't seem to work. Please suggest a way out.

    Thanks in advance,

    Anirban

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.