Skip to Content
0

Running SAP GUI Scripting with SQL Server Agent STILL gives popup window (notifications turned off)

Mar 01, 2017 at 03:56 PM

75

avatar image

I already know about turning off the notifications in options\accessibility\scripting. And when I run my package in Visual Studio it does not popup (notifications are turned off).

BUT when I try to run the package using SQL Server Agent (as a service) I get Interactive Services Detection popup which then shows a different desktop (presumably a different session) with the "SAP Logon" window.

What I think is happening: It seems that SAPGUI is running in a different session than regular user (hence the window change) and I cannot find how to set the SAP Netweaver App's scripting settings for that session. I log in to windows on Session 1, but Services are running on Session 0 and even though I changed the settings in Session 1, 0 is still running default.

- How do I avoid this popup? I believe I need to change the Session 0 SAP options - how do I do that?

I am using:

SAPGUI 730, SSDT 2013 (scripts written in c#), SQL SERVER 2012, Windows 7 64bit.

thanks in advance!

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Luis Darui
Mar 01, 2017 at 04:10 PM
0

Hi Robert,

I don't really think SQL Server will play anything there, but my guess it can be related to the user that runs the SQL Server Agent. By default, it is installed and configured to run under the account 'NT Service\SQLSERVERAGENT'. If this user is calling the SAP GUI then it can be the case that you need to change this account to your own account or another account which you can also logon interactively to change the SAPGUI configuration and make it persist.

Best regards,

Luis

Share
10 |10000 characters needed characters left characters exceeded