Skip to Content
0

STMS - Importing transport requests (using script)

Mar 01, 2017 at 11:54 AM

257

avatar image

Hello,

Some years ago I created the following thread here in SCN SAP community:

https://archive.sap.com/discussions/thread/3832253


I need to import a lot transport requests in a SAP system (sandbox).

Now, I need the same solution but for running in OS400 (iseries IBM) platform! It´s possible to run scripts using the QSHELL (command: STRQSH)?

I don´t have so much experience in iseries platforms therefore I have a lot of doubts!

How can I run Unix scripts in OS400 (iseries)?

Any tips?


Best regards,

João Dimas

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Christian Bartels
Mar 01, 2017 at 02:38 PM
0

IBM i (formerly known as OS/400) has two Unix-style shells: QSHELL and QP2TERM. They both can execute scripts, but there are differences in how they deal with text file processing (EBCDIC/ASCII conversion). A detailed discussion about both tools can be found in this archived blog entry: https://blogs.sap.com/2016/04/08/sap-on-ibm-i-update-week-14-2016-problems-starting-the-sap-software-update-manager-on-ibm-i-and-mistakes-using-qsh-vs-qp2term/. For the use with SAP tools, we recommend to use QP2TERM rather than QSHELL.

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hello Christian Bartels,

For this example, I need to import the Transport Request QS1K939345 in S03 SAP system, and for that first I need to add to buffer this transport request and then the importing of it! The P01 SAP system is the domain controller of STMS.


Unfortunately the command that I ran is not working (addtobuffer)... I don´t know why. Can you tell me please why and help me?


I tried to run the tp command manually using the QP2TERM. For this I typed:

> call qp2term

> /usr/sap/S03/SYS/exe/run/tp addtobuffer QS1K939345 S03 pf=/sapmnt/trans/bin/TP_DOMAIN_P01.PFL

This is /usr/sap/S03/SYS/exe/run/tp version 380.20.11 (release 721)
ERROR: too many arguments (other than named options)
Usage of command ADDTOBUFFER:
tp ADDTOBUFFER <TR> <SAPSID> [options ...]
Appends the transport request <TR> to the buffer of system <SAPSID>
Options:
U<nnn> specify one or more unconditional modes
buffer=<file> use <file> as the buffer (<SAPSID> has to be omitted)
tag=SPAM|X handle only tagged buffer entries
remote=<SAPSID> take <SAPSID> as remote system that
transferred/received the entry (TMS only)
before <E-TR> insert buffer entry before <E-TR>
after <E-TR> insert buffer entry after <E-TR>
pf=<TPPARAM> specify a transport parameter file
silent redirect stdout to dev_tp in current directory
-D"<entry>" specify a parameter for tp
-t<k> specify a trace level for tp
tf=<filename> specify the name of a trace file for tp
shdwtadir=<tabname> specify the name of a shadow TADIR
Description of arguments:
<TPPARAM> (complete) path of a transport parameter file
<entry> a parameter description as in a tp parameter file
<TR> transport request, e.g. C11K904711
<SAPSID> R/3 system's name, (target or source whatever is appropriate)
<nnn> umode digits, i.e. 0,1,2,..,9
<E-TR> an existing transport request (being already in the buffer)
clients for both (<TR> and <E-TR>)
can be specified with the 'client' option
tp returncode summary:
TOOLS: Highest return code of single steps was: 0
ERRORS: Highest tp internal error was: 0203
tp finished with return code: 203
meaning:
wrong syntax in tp call
$



Can you help me please?


Best regards,
João Dimas

0
Christian Bartels
Mar 02, 2017 at 12:40 PM
0

When I specify the command in the given way, I do not get an error. Did you signon as <SID>ADM or execute program R3<sid>400/R3INLPGM to setup a proper environment before executing the tp command?

Kind regards,

Christian Bartels.

Share
10 |10000 characters needed characters left characters exceeded