Skip to Content
author's profile photo Former Member
Former Member

data not show SMART

i use smartform and i declare the right declaration

( i create a ztale like itab)

but now i dont see the data in the layout

i declare:

FORM I--->>>>zmytable like ztable

GLOBAL--->>>>lwa_zmytable type ztable

in the main window

i want to create a text with ALL the ROW

&lwa_zmytable&

what's wrong???

thanks

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Jun 15, 2006 at 09:36 AM

    Hi,

    In the main window you have to create a TABLE NODE. Then in the DATA tab of this table node you have to give the internal table and the work area. Then in the GENERAL ATTRIBUTES tab of this table node define TABLE LINES. And then in the MAIN AREA creat a table line. Then in the CELLS so obtained create a TEXT and give the work are fields over there.

    Please mark the answer if helpfull...

    Thanks and Regards,

    Bharat Kumar Reddy.V

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jun 15, 2006 at 09:38 AM

    Hi Liat,

    Did you populate the data in the print program?

    Did you keep the &lwa_zmytable& in a loop /table element?

    2) Try to give &lwa_zmytable-field1&,,&lwa_zmytable-field2& instead of &lwa_zmytable&

    Regards,

    Ravi

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 15, 2006 at 09:38 AM

    have you declared a table in your smartform? and declare zmytable and loop at lwa_zmytable.

    you cannot use &lwa_zmytable& you have to access them by fields by dragging them from the field list into a cell.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 15, 2006 at 09:43 AM

    Hi Liat,

    Have you created a table ZTABLE in SE11 like your internal table in print program.

    Better approach is, create a structure ZTABLE in SE11, Save it, Activate it.

    Now, Create a TABLE TYPE (ZTT) in SE11 for using ZTABLE. Save it and Activate it.

    In Smartforms,

    Form interface, TABLES tab,

    declare zmytable TYPE ZTT.

    GLOBAL --> lwa_zmytable TYPE ZTABLE.

    Now, in the MAIN WINDOW, create TABLE object and keep the pass the parameters as below.

    ZMYTABLE INTO lwa_zmytable.

    now, you can use &lwa_zmytable& in your text elements.

    Dont forget to check the syntax, save it and activate it.

    regards,

    ram

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.