Skip to Content
0
Former Member
Jun 14, 2006 at 01:35 PM

Build can't see public part

16 Views

I'm getting a really strange error. When the CBS tried to build a DC, I see this message in the request log:

Using generic UNIX platform support.
	Synchronize sources... finished at 2006-06-14 13:25:50.710 GMT and took 2 s 105 ms
	Synchronize used libraries...
		"company.ca/wl/details/wd"  in compartment "company.ca_TRACK_1" 
                           cannot be built and will be marked as BROKEN.
			Used component "company.ca/wl/models/user/wd" has NO 
                           PUBLIC PART with name "compilation". Such a public 
                           part has not yet been defined or activated.
			[DC 181 variant "default"][SC 71] using [PP "compilation" of
                           DC 166 variant "default"][SC 71][last successful build: 399]
		public part "default" of component "sap.com/com.sap.exception" ... OK
                (etc)

Now, the DC in question, /wl/models/user/wd, does in fact have a public part called 'compilation' - the public part shows up in the CBS ui. I've tried rebuilding DC /wl/models/user/wd, followed by rebuilding the /wl/details/wd DC, but I keep getting the same error.

As near as I can tell, all activities have been activated, so everything should be in sync.

Anyone have any ideas how I can go about solving this issue?