Skip to Content
avatar image
Former Member

Objects missing in the database

Hi All,

I just completed a system copy for a BW3.1C system on AS400(version v5r3) from production. The system is back up after the refresh. But when i go to Db02->consistency check>DB & ABAP dictionary check>new check

It shows me Objects missing in Database and beneath the table header it shows me *084 tables missing and in views shows me 2084 views missing.

I checked in the DB at the OS level. These table and views all of these exist in the Databse library R3<SID>DATA. Just to confirm, i also tried creating these from DB02 by clicking on "create in DB" and it came back with the error "table already exists in database.

While restoring I used the normal restore commands "RSTLIB SAVLIB(<source_database_library>) DEV(SAVF) SAVF(<lib>/<file>) OPTION(NEW) RSTLIB(R3<target_SID>DATA) OUTPUT(PRINT) MBROPT(ALL) ALWOBJDIF(*ALL)"

What am I doing wrong? Is there a way i can fix this or what other options do i have??

Thanks

Abhi

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    avatar image
    Former Member
    Jun 12, 2006 at 04:42 PM

    Hi Abhi,

    Does it look like what Note 66985 describes? If yes (SYS* views still point to the previous R3SIDDATA library), just do

    CALL PGM(QSYS2/QSQXRLF) PARM('DLT' 'R3<SID>DATA')

    then

    CALL PGM(QSYS2/QSQXRLF) PARM('CRT' 'R3<SID>DATA')

    Good luck,

    Victor Lin

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Victor,

      Thanks a lot for the reply. This solved my problem.

      Many-2 many-2 thanks to u..I have given u full points...

      If I had more points to give..I would have given you 100 points...This error was driving me crazy..

      Thanks a lot

      Abhi