Skip to Content
avatar image
Former Member

did not accept login request as admin on port 50018

Dear Reader(s),

Below is the ERROR MESSAGE I get when I deploy from my local NetWeaver Developer Studio to the (remote) J2EE application server.

-


In NWDS I made the following settings:

NWDS/Window/Preferences/SAP J2EE Engine

Message Server Host: serversap01

Message Server Port: 3601

-


I assume the J2EE_ADMIN user is used when establishing a connection between NWDS and the application server?

When I use the remote GUI from SDM on the server I can see the http server configuration on port 50019 is not running. Can this be the reason?

-


ERROR MESSAGE:

SDM host : serversap01

SDM port : 50018

URL to deploy : file:/C:/DOCUME1/jasper/LOCALS1/Temp/temp16161Calculator_Sol_EAR.ear

Deployment exception : Server serversap01 did not accept login request as admin on port 50018.

Details: ERROR: Could not establish connection to server serversap01 at port 50018: Connection timed out: connect

Inner exception was :

Server serversap01 did not accept login request as admin on port 50018. Details:

ERROR: Could not establish connection to server serversap01 at port 50018: Connection timed out: connect

-


Please can anyone advise? Thanks in advance, Jasper

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Best Answer
    Jun 12, 2006 at 12:34 PM

    Hello Jasper,

    This problem occurs when from someone is already logged in to the SDM server.

    SDM server can accept only one connection.

    Regards

    Sidharth

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 03, 2006 at 07:52 AM

    Hello! I'm in a similar situation with Jasper, where I have to deploy from my local NWDS to the remote J2EE Engine and get the same error message.

    Jul 3, 2006 3:24:27 PM /userOut/deploy (com.sap.ide.eclipse.sdm.threading.DeployThreadManager) [Thread[Deploy Thread,5,main]] ERROR:

    [002]Deployment aborted

    Settings

    SDM host : servername

    SDM port : 50218

    URL to deploy : file:XXXXX

    Deployment exception : Server servername did not accept login request as admin on port 50218. Details: ERROR: Could not establish connection to server servername at port 50218: Connection timed out: connect

    Inner exception was :

    Server servername did not accept login request as admin on port 50218. Details: ERROR: Could not establish connection to server servername at port 50218: Connection timed out: connect

    In NWDS I made the following settings:

    NWDS/Window/Preferences/SAP J2EE Engine

    Message Server Host: servername

    Message Server Port: 3603

    I also did SAP note 783965. But I'm still getting this error message.

    Do I still have some more configurations to do before this thing works? I'm not using VPN. Can anyone please advice? Thanks in advance.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 03, 2006 at 07:52 AM

    Hello! I'm in a similar situation with Jasper, where I have to deploy from my local NWDS to the remote J2EE Engine and get the same error message.

    Jul 3, 2006 3:24:27 PM /userOut/deploy (com.sap.ide.eclipse.sdm.threading.DeployThreadManager) [Thread[Deploy Thread,5,main]] ERROR:

    [002]Deployment aborted

    Settings

    SDM host : servername

    SDM port : 50218

    URL to deploy : file:XXXXX

    Deployment exception : Server servername did not accept login request as admin on port 50218. Details: ERROR: Could not establish connection to server servername at port 50218: Connection timed out: connect

    Inner exception was :

    Server servername did not accept login request as admin on port 50218. Details: ERROR: Could not establish connection to server servername at port 50218: Connection timed out: connect

    In NWDS I made the following settings:

    NWDS/Window/Preferences/SAP J2EE Engine

    Message Server Host: servername

    Message Server Port: 3603

    I also did SAP note 783965. But I'm still getting this error message.

    Do I still have some more configurations to do before this thing works? I'm not using VPN. Can anyone please advice? Thanks in advance.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      We also had this problem today so I thought I'd add our info to the thread.

      The timing of our problem today was such that we suspected, but couldn't be sure, it was related to a hardware move for our "Test" portal onto a new IP. (The problem was when importing to test.) After trying and verifying numerous things, we opted to restart the NWDI SAP instance. This resolved our problem.

      If it was related to the portal box move, then we theorized that the IP address might have been cached somewhere. If it wasn't related to the portal box move, then we just took the Microsoft Windows approach (reboot) and it worked.

      Carol

  • avatar image
    Former Member
    Sep 10, 2010 at 11:02 PM

    I was with the same problem!!

    Sep 10, 2010 7:39:13 PM /userOut/deploy (com.sap.ide.eclipse.sdm.threading.DeployThreadManager) [Thread[Deploy Thread,5,main]] ERROR:

    [001]Deployment aborted

    Settings

    SDM host : lnw

    SDM port : 50018

    URL to deploy : file:/C:/DOCUME1/raphael/LOCALS1/Temp/temp4525043136276466867Rabitus.ear

    Deployment exception : Server lnw did not accept login request as admin on port 50018. Details: ERROR: Could not establish connection to server lnw at port 50018: Connection timed out: connect

    Inner exception was :

    Server lnw did not accept login request as admin on port 50018. Details: ERROR: Could not establish connection to server lnw at port 50018: Connection timed out: connect

    the problem was solved by two steps

    1. in the host file i added

    192.168.0.99 lnw

    2. verify if port 50018 is willy allow trought net

    to verify that, i used the FREEPORTSCANER software free that u can find in www.baixaki.com.br

    in my case, that port was block, so i put that port 50018 with the ip in the router configuration and the problem was solved

    I hope that tip be useful

    Add comment
    10|10000 characters needed characters exceeded

  • Sep 13, 2010 at 07:47 AM

    Hi,

    one tip just crossed my mind: you can also use the command

    netstat -a

    to figure out whether the given port is open.

    Regards,

    Ervin

    Add comment
    10|10000 characters needed characters exceeded

    • Hi,

      if the engine where you intend to deploy is higher equal to 710 then the port is 5xx04 else (this is the 70X case) it is 5xx18.

      5xx04 stands for the P4 protocol and used by the deploy controller as of 710,

      5xx18 stands for the sdm port used by SDM on 640/70X.

      Are you sure you are using the correct port number?

      Best Regards,

      Ervin