Skip to Content
author's profile photo Former Member
Former Member

Enhancement fields - Replication of Data Source problem

Hi,

I am using standard Data Sources: 0FI_GL_4, 0FI_AR_4 AND 0FI_AP_4 for extraction of data from R/3 in to SAP BW. I am appending the new required fields for the above mentioned extractors by using enhancements.

After replicating the <i><b>replicate data source</b></i> in BW side, we observed that the enhanced fields of 0fi_gl_4 were replicating in transfer structure of SAP BW side, but 0FI_AR_4 AND 0FI_AP_4 fields were not replicating at transfer structure of BW.

Please advice me - is there any setting or coding part i need to perform to add newly enhance fields in transfer structure of data source: 0FI-AR-4 AND 0FI-AP-4.

Thanks & Best Regards,

Venkata.

Add a comment
10|10000 characters needed characters exceeded

Related questions

4 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jun 12, 2006 at 07:08 AM

    Hi Venkata,

    Please try the below 2 approaches to get this working.

    1st Approach.

    -


    Go to RSA6 and select your data source and unhide your fields.

    2nd Approach.

    -


    If the above does not help this is what you should check.

    The properties of all the fields of a Data Source is stored in a table called ROOSFIELD (DataSource Fields).

    Step 1 ->Please go to SE11 and open the table - ROOSFIELD. Give the name of your Data Source in the Selection field OLTPSOURCE of the selection screen.

    Step 2 -> Run this and check the 2 properties SELECTION and NOTEXREL of the enhanced fields of the data source.

    Step 3 -> The enhanced fields should have the SELECTION field as ' ', 'P' or 'X'. It should not be 'A'.

    Similarly the NOTEXREL field for the enhanced fields should be 'Y' and not 'N'.

    These 2 fields would need to be updated in case they are not set.

    There are several NOTES available if the above diagnosis are correct.

    Hope this helps.

    Thanks & Regards,

    SH

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 12, 2006 at 06:05 AM

    hi venkata

    can you send the steps how you did that

    and if possible code also

    Regards

    Vasu

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 12, 2006 at 06:23 AM

    Hi Venkata,

    Pls check whether the newly added fields were in "HIDDEN" in the datasource. This can be a reason.

    Thanks,

    Krish

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jun 12, 2006 at 06:27 AM

    Hi Venkat,

    After enhancing the extract structure did you remove the tick in hide check box in T-Code RSA6 for data sources 0FI_AR_4 AND 0FI_AP_4 .

    Regards,

    Prakash

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.