Skip to Content
0

Run on simulator options disabled for Kapsel Offline application

Feb 28, 2017 at 11:14 AM

209

avatar image

Hi Experts,

I have built a Kapsel offline application using Web IDE and Hybrid Application Toolkit following this document How to Create a Kapsel OfflineApplication Using SAP Web IDE and Hybrid Application Toolkit.

I have completed all prerequisites, created the application project (using template SAPUI5 Master Detail Kapsel Offline template), setup the application ID on HCPMS and configured and deployed the application to the device.

Now when I try to run the app by right-clicking the project -> Run -> Run on Local Device/Simulator as given in section 6 point 9, I see that the options that show up here like Android emulator, iOS Emulator, iOS Device etc. are disabled and I cannot select any of them.

Can anyone let me know what I have to do so that the run on simulator options get enabled?

Regards,

Saurabh

capture.png (72.2 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Jamie Cawley
Feb 28, 2017 at 01:25 PM
0

Do you have hat running and did you choose a platform in the hybrid app configuration?

Regards,

Jamie

SAP - Technology RIG

Share
10 |10000 characters needed characters left characters exceeded
saurabh vakil Feb 28, 2017 at 02:56 PM
0

Hello Jamie,

Thanks for your response. I do have the HAT plugin running. Also I have configured Android and iOS under Platforms in the hybrid app configuration as shown in the attached images.

Regards,

Saurabh


capture.png (25.4 kB)
capture2.png (61.1 kB)
Show 3 Share
10 |10000 characters needed characters left characters exceeded

Make sure you are right clicking on your project folder, OfflineApp and not a subfolder.

Regards,

Jamie

SAP - Technology RIG

0

Hello Jamie,

Yes, I am right clicking on the main project folder OfflineApp and not on a subfolder. Also now I have observed a change in the original issue I had posted - now when I right click on the project folder and go to Run -> Run on Local Device/Simulator I can see the options Android Emulator and Android Devices are enabled. But still when I select Android Emulator I can see the error popup shown below.

Also in the console I can see the below message:

(hybrid-toolkit) The emulate command execute failure reason: If the HAT Connector is not available, restart the Connector server and try again.

Also check that the port values are identical in both Web IDE HAT preferences and the Connector config.json file.

If problems persist, check the Connector command window for errors, and review the Web IDE console (switch to Development tab and select View > Console) troubleshooting guidance.

capture.png (46.1 kB)
0

Did you install and start the HAT connector? Use the "more information" shown in the plugins dialog if you haven't installed it.

Regards,

Jamie

SAP - Technology RIG

0
avatar image
Former Member
Nov 28, 2017 at 08:54 AM
0

Hi Saurabh,

Did you solve your problem? Could you please provide some help? I met the same problem.

Thanks and Regards,

Sandy

Share
10 |10000 characters needed characters left characters exceeded