Skip to Content
author's profile photo Former Member
Former Member

GUI_UPLOAD and Unicode

Hi,

I want to use GUI_UPLOAD to load an ASCII file with Czech Characters. I try to save my file in .txt format UTF-8. If i read the file with notepad then i have all my characters but when i load in SAP I lost some characters - Who have a solution - I'm in 4.6C - I put in SAPlogon page code 1404 and language CS .

DATA: BEGIN OF f1 OCCURS 0,

altkn(10) TYPE c,

bldat(10) TYPE c, "tt.mm.jj

rart(15) TYPE c,

  • insert michel

zuonr(18),

*

xblnr(20) TYPE c,

  • name1(40) TYPE c,

waers(5) TYPE c,

brutt(13) TYPE c,

fwbtr(13) TYPE c,

faedt(10) TYPE c,

zterm(4) TYPE c,

kunnr(10) TYPE c,

sgtxt(49) TYPE c, => i can find VANĚK

....

CALL FUNCTION 'GUI_UPLOAD'

EXPORTING

filename = pcfil

  • FILETYPE = 'BIN'

has_field_separator = fsepa

  • HEADER_LENGTH = 0

  • READ_BY_LINE = 'X'

  • DAT_MODE = ' '

CODEPAGE = 'UTF8'

  • IGNORE_CERR = ABAP_TRUE

  • REPLACEMENT = '#'

CHECK_BOM = 'X'

IMPORTING

filelength = rc

  • HEADER =

TABLES

data_tab = f1

EXCEPTIONS

file_open_error = 1

....

Thanks

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jun 07, 2006 at 06:08 PM

    Do not use UTF-8 when saving in notepad, do u have a non unicode option in notepad, we have ANSI in US english.

    is ur PC system language also czech?

    Regards

    Sridhar

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      My Pc is in French Language.

      I try - saving Excel File in unicode - Opening this file with notepad and saving in ANSI - Result : It's the best until now, I does not lose the character in its entirety, only certain accent. we are touching the solution - have you something else ?

  • author's profile photo Former Member
    Former Member
    Posted on Jun 08, 2006 at 07:46 AM

    u have to uplaod the font of Czech Characters

    into ur local pc.

    1)At the Operating system level install the Czech language.[Control panel - >Regional and language Option - >language Tab - > Click on Install Files for Czech languages] If these language already installed then click on Detail and add the Czech languages 2) At SAP level click on Customizing of Local layout[Alt+F12] and click on options.Go to tab I18N and click on Activate the multi-byte functionalities to support check box.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Are you using windows XP?

      In the PC regional settings, go to advanced tab and change Language for non-unicode programs to Czech. You might need to restart the system.

      If you are using SAPGUI 6.2 and above, keep the logon pad language settings default.

      save the file in notepad using default first, if all characters are not showing up, try ansi.

      What code page is your 4.6c appserver is using for language CS?

      Regards

      Sridhar

  • author's profile photo Former Member
    Former Member
    Posted on Jun 07, 2006 at 06:15 PM

    Hi,

    Try Saving the notepad file in Unicode Encoding..

    I guess that should solve the problem..

    Hope that helps

    Regards,

    Tanveer.

    <b>Please mark helpful answers</b>

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.