Skip to Content
0

Fiori Launchpad update "currentState" Error

Feb 27, 2017 at 10:59 AM

166

avatar image

Hi,

We updated gateway system to Fiori 2.0. When testing applications on fiori luanchpad, we are getting error like 'Resource not found for the segment 'currentState'. '.

We cleared application cache but any thing not changed.

When i call application on directly url , i am not getting error. For this reason i am thinking , it's about launchpad update.

Sytem component verison and error is as follows.

Can any body help?

gw1.png (38.0 kB)
gw2.png (404.1 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Keith Nunn
Mar 28, 2017 at 05:41 PM
0

Hi, Abdullah.

If you haven't resolved this yet, I wanted to suggest checking the Component.js for your custom UI5 application(s). Verify when you use setModel() to register your OData model that you are registering it using this.setModel() instead of sap.ui.getCore().setModel(). If you do the latter it ends up setting this as the default model for all controls, even those not within your application's component.

Thanks,

Keith Nunn
SAP Product Support

Share
10 |10000 characters needed characters left characters exceeded
Abdullah GUNES Apr 05, 2017 at 06:08 PM
0

Hi Keith,

Thanks for your replying.

I checked everything I could control, but i not found anything.

At last , i tried to update UI library to version 1.40.18 , and finally it worked for my problem, now everything is ok.

I thing there can be a bug in before version of UI library.

Share
10 |10000 characters needed characters left characters exceeded