Skip to Content
avatar image
Former Member

BPC Procedure/Function not found in catalog for Characteristic Relationship

Hi, I have created a CR in BPC of type class. The class is derived from

CL_RSPLS_CR_EXIT_BASE.

I then implemented method get_sqlscript_info and the derive method as follows:

method if_rspls_cr_exit_hdb~get_sqlscript_info.
    e_procedure_name_derive ='ZCL_CR_CPRC01_002=>AMDP_DERIVE2'.endmethod.method amdp_derive2 bydatabaseprocedureforhdblanguagesqlscriptoptionsread-onlyusing/bi0/pcust_sales.
    e_t_chas =SELECT cust."CUST_SALES" AS "SOLD_TO",
           cust."SALESORG",
           cust."DISTR_CHAN",
           cust."DIVISION",
           cust."CUST_GROUP",
           cust."SALES_OFF"FROM:i_t_chas AS IT
        INNERJOIN"/BI0/PCUST_SALES" AS custON  it."SOLD_TO"    = cust.CUST_SALES and
            it."SALESORG"      = cust."SALESORG" and
            it."DISTR_CHAN"    = cust."DISTR_CHAN" and
            it."DIVISION"      = cust."DIVISION";endmethod.

When executing the CR is RSPLAN, I get a short dump. On HANA trace, I get the following:

[22571]{400160}[75/291939343] 2017-02-21 04:26:31.309290 e pleCompile ple_command_srv.cpp(00199) : Invalidate the session '20170221022630_7360000' due to an exception. Session '20170221022630_7360000' not valid.

Last error: Condition 'fi' failed.

Procedure/Function 'SAPMAL'.'ZCL_CR_CPRC01_002=>AMDP_DERIVE2' not found in catalog!

What am I doing wrong, any help would be appreciated.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Mar 01, 2017 at 12:19 PM
    -1

    Hi Lambertus,

    if not done already active the ABAP class containing the AMDP methods again. Usually the DB artefacts are created in the first method calls.

    In PAK the the 'life cycle management' is triggered in CL_RSR_PE_ADAPTER->IF_RSR_PE_ADAPTER~EXECUTE_SQL_SCRIPT

    ...

    ...
    cl_amdp_runtime_services=>prepare_class_for_call( im_class_name = l_amdp_class_name ).
    ...
    

    You can check whether you get any exceptions here.

    Regards,

    Gregor

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 23, 2017 at 05:22 PM

    HI Lambertus,

    Any update to this issue. I am facing the same . however I tried reactivating the AMDP class and checked for exceptions using the cl_amdp_runtime_services class.

    Thanks,

    Sanjay

    ,

    Hi Lambertus / Gregory,

    ANy update to this post, I am facing the same issue tried to reactivate the class and also checked for any exceptions using the

    cl_amdp_runtime_services.

    Thanks ,

    Sanjay

    Add comment
    10|10000 characters needed characters exceeded

  • Mar 28, 2017 at 08:17 AM

    Hi Sanjay,

    I have not yet seen this effect. Do you get any exception in cl_amdp_runtime_services? You may debug this class to get the name of the procedure on the HANA side and check the procedure with HANA Studio. If you cannot find the procedure then maybe there exist a problem in the AMDP infrastructure. You can search for note in component BC*.

    Regards,

    Gregor

    Add comment
    10|10000 characters needed characters exceeded