Skip to Content
avatar image
Former Member

Termination of /SAPAPO/SAPLOO_TS_DM while extracting the APO datasource

Hi All,

I am facing some peculiar problem while I run the RSA3 for the planning area datasource in quality box of APO system.

I have generated the datasource for planning area with the option Generate datasource in the planning area view from Extras menu item. This is transported to the quality box and whien i try rsa3 for the same its giving short dump saying /1APO/EXT_STRU110000123 (extract structure) is unknown type. this structure is getting generated dynamically. I checked the extract structure of the datasource in rsa2 there its showing /1APO/EXT_STRU110000172 which is same as in the development box.

Just to verify whether this is a transportaion problem or not I created the a test datasource for the same planning area in the quality box. then i checked the extract structure in rsa2 it shows me /1APO/EXT_STRU110000172 but when i run it in rsa3 same problem, dump saying /1APO/EXT_STRU110000123 (extract structure) is unknown type.

Does anyone faced this similar problem. Pls I shall be much obliged to all who give me the solution for this, since its very ugent for me.

nagam.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    avatar image
    Former Member
    May 30, 2006 at 01:03 AM

    Hi,

    Just a thought that maybe you can check.

    Can you check whether you have implemented BADI /SAPAPO/SDP_EXTRACT (specifically interface CHANGE_OUTPUT)? Maybe someone has hardcoded the /1APO/EXT_STRU110000123 type in the ABAP routine there and it is the one which is causing the dump. If you have implemented the BADI, then the implementation gets called when you extract data from the planning area (e.g. using RSA3) and the codes there may have caused the dump...

    Furthermore, can you post the dump screen here? or send it to me via email. I want to pinpoint just where the dump occured.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Emmanuel,

      First of all my apologies for replying yu very late because of some holidays here.

      Wht ever Emmanuel said and Ian suggested is correct. It has solved my problem.

      Thanx a lot, I am assigning right pts for this favour.

      Once again Thanx a Lot.

      rgds

      Narendra.