Skip to Content

Problem with symbol #

Hi All,

While posting an IDOC from my R3 system, one of my fields contained the symbol <b>#</b> and the corresponding scenario errored out in XI.

When I opened the incoming payload, from MONI, I observed that <b>the symbol # was being replaced by a rectangular box in my payload</b>, and that as the reason for the problem.

When I used WE19, to test the same IDOC again, it seems to work fine.<b> If I manually enter the # in WE19, I face no problem watsoever. But when the IDOC is being sent by the R3 system, it seems to error out as stated above.</b>

any ideas as to why this must be happening?

Regards,

Bhavesh

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    May 29, 2006 at 03:52 AM

    HI Bhavesh,

    Please can you check in your RFC Destination, AI_RUNTIME_JCOSERVER, Tab Unicode

    Character conversion

    Take Default setting and put

    'Ignore Error, Error Indicator: '#' = U+0023'

    Regards

    Vijaya

    Add comment
    10|10000 characters needed characters exceeded

    • hi,

      >>>>when I test the same IDOC from We19 with the # symbol, I see no issue at all. The # is passed as such to XI.

      I know but when you do we19 it might be something different (other codepage for example)

      there are some sap notes with that search for:

      IDOC #TEXT, IDOC adapter #TEXT

      #TEXT <- is a key word in this case:)

      >>>>I am using JAVA mapping

      maybe you can check you java mapping?

      why it's erroring out? - do oyu convert the codepage

      or anything? or maybe you can check for that strange

      character and replace it?

      Regards,

      michal

  • Jan 02, 2008 at 02:00 AM

    Was a bug in the Idoc adapter.

    OSS with SAP solved the problem.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      hi Bhavesh,

      Can you tell me the OSS number for this issue?

      I see this issue in Production. We have tried sending the messages from Development and Quality but this issue is not observed there. Note that the message is not getting errored out.

      Only the # character gets removed and gets replaced by CR (0A) character.

      regards,

      Anirudh Vyas