Skip to Content
Mar 31 at 04:38 PM

CAP Service returns 503 service unavailable when run through app router


I am learning CAP and i am struck with the following issue. Seeking community help to help me fix and learn. I created a CAP service (sample bookshop srv) and deployed the application to BTP. While executing the app router locally, i can see the data is fetched correctly and data is displayed in the UI5 application. But after deploying to BTP, when i run the app router i get the error, Service Unavailable.

the service call returns 503 service unavailable when executed through App router, and 401 unauthorized when running the service instance. I did not define any restriction in my CAP Service.

I tried deleting the services and deploy it again. I tried adding a role in the xs-security.json and assigned the role to my user. It did not work. I have attached the mta.yaml, xs-app.json, xs-security.json file. i appreciate if someone can help.


Arun K

mta.txt xs-app.txt xs-security.txt


mta.txt (2.4 kB)
xs-app.txt (730 B)
xs-security.txt (686 B)