Skip to Content
Jan 18 at 08:39 PM

Integration Suit - not working


I subscribed to integration suite in BTP trial account. I did add the build integration scenarios and Manage API to the capabilities. The capabilities got activated. After that I went back to BTP trial account and enabled the active capabilities under boosters -> enable integration suite.

However when I go to application I did not see discover integrations or design / discocer API in the tiles. Did not see any navigation to the discover / design / monitor -> Integrations / API

So to start fresh I tried to delete / unsubscribe.

I could delete the defaut_it-rt_api process integration runtime instance however could not delete the default_it-rt_integration-flow.

It gave ERROR Couldn't delete service instance default_it-rt_integration-flow.

Reasons: The instance has service keys. Please delete them before you proceed to delete the instance.

Then I tried deleting the service key It gave following error

Couldn't delete service key 'defaultKey_67e1ce82-4921-4de7-9446-f5bb8adc195d'. Please view details for more information.

Service broker failed to delete service binding for instance default_it-rt_integration-flow: Service broker error: Service broker it-broker-rt failed with: Error occurred during deletion of binding d59cc589-9607-4f29-9a94-5af4999e8934 of instance 67e1ce82-4921-4de7-9446-f5bb8adc195d

Here nstance 67e1ce82-4921-4de7-9446-f5bb8adc195d is the default_it-rt_integration-flow However I do not know what is


I tried to execute update on instance default_it-rt_integration-flow and it failed saying

Service broker error: Service broker it-broker-rt failed with: UAA clone-instance lookup failed with statuscode: 400

If I tried to delete the subscription it fails saying

Couldn't unsubscribe from Integration Suite. Try again. If the problem persists, please post a question to SAP Community.

Now that multiple things may be broken If I go to application for integration suite I get following error

No client with requested id: sb-it-prov!t55215

I also tried boosters -> enable integration suite -> configure subaccount but it says

SAP Integration Suite application is not subscribed. Please subscribe the application and activate capabilities manually to proceed.

I wold appreciate any help getting the integration suite working on a clean slate



View Credentials