Skip to Content
0

Not able to find ESR Objects in Sproxy

Feb 23, 2017 at 01:35 PM

436

avatar image

Hi Experts,

I am trying to setup proxy communication with the SAP system from SAP PI 7.5 single stack. I did all the required settings in ECC and in NWA using the below link

http://saptechnical.com/Tutorials/XI/Proxy/AAE.htm

I have created two RFC destinations of Type G.

  1. RFC Destination (G) - SAP_PROXY_ESR
    1. Path: /rep
  2. RFC Destination (G) - Channel to PI
    1. Path: /XISOAPAdapter/MessageServlet?ximessage=true

RFC Destination (T) - SAPSLDAPI

  1. Program ID: JCo Service Provider, created Program ID in NWA.

done with SLDAPICUST and the connection is working fine.

Setup SXMB_ADM - Integration Engine Configuration

I also checked SLDACCESS and it is also working fine.below is the screen shot.

When I go into Sproxy I am not able to find the any ESR objects, but when I try to search using search option I am able to see the corresponding namespace and Service interface in the search option.

Please suggest me why I am not able to see the ESR objects in Sproxy including the basis objects also, did I miss any thing. When I try for the SWCV in search I am getting no value found.

sldcheck.jpg (51.9 kB)
sproxy.jpg (82.3 kB)
sproxy1.jpg (77.5 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

9 Answers

Best Answer
ratnakumar injedu Mar 01, 2017 at 07:51 AM
0

Thanks all for the response and support.

Hi Avinash,

Now the issue got resolved. I linked the SAP Basis SWCV with the product.

But the issue got resolved once I created the SWV with the vendor name other than sap.com. The esr objects are now seen in SPROXY.

Thanks,

Ratna

Share
10 |10000 characters needed characters left characters exceeded
Evgeniy Kolmakov Feb 23, 2017 at 02:34 PM
0

Hi Ratnakumar!

Is "poptadev" your back-end SAP system?

Regards, Evgeniy.

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Evgeniy,

Thanks for the response.

poptadev is not the back end SAP system. It is the host name for SAP PI system.

Thanks and Regards,

Ratnakumar

0
Raghuraman S Feb 24, 2017 at 11:33 AM
0

Check ur filters.Might be something disabled by mistake.

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Raghuraman,

I have checked the filters nothing is disabled.

Actually PI system is newly set up one. I just imported a software component in to ESR and created the corresponding DT, MT and SI after completion of proxy configurations to check if I can find the ESR objects in SPROXY. But I could't find any ESR objects as mentioned above.

The SWCV SAP BASIS 7.50 has not got assigned with the product in SLD, will it be the cause for the ESR objects not reflecting in the ESR. If this would be the reason please suggest me how can I assign the product to the SWCV SAP BASIS 7.50.

Thanks and Regards,

Ratnakumar

0
Rameshkumar Varanganti Feb 24, 2017 at 09:49 PM
0

Go to Sproxy-->Utilities-->Proxy genaration

Then Select capture.png ESRBrowser in Enterprise Service Browser and exit from Tcode.

Again Open SPROXY and now you will be able to see


capture.png (5.3 kB)
Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi Rameshkumar,

Thanks for the response.

Sorry for the delay. I tried to change Sproxy-->Utilities-->Proxy genaration. but I am not able to find the ESR Service browser option. Please find the screen shot on my SPROXY attached.

sproxy27.png (54.7 kB)
0

Hi Rameshkumar,

Actually the SAP Basis 7.50 SWCV in ESR is not assigned with any product in the SLD, will it make any difference. Please suggest me the necessary changes we can make to assign the product if it make any difference in the ESR.

Thanks a lot in advance.

Thanks and Regards,

Ratnakumar

0
Goradindla Sreerama Reddy Feb 24, 2017 at 11:23 PM
0

Hi,

Can you test if your RFC -SAP_PROXY_ESR is working fine in SM59.

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Sreerama,

Thanks for the response. the test for SAP_PROXY_ESR is working fine.

PFA the screen shot attached.

proxy-esr.png (30.3 kB)
0
Goradindla Sreerama Reddy Feb 24, 2017 at 11:24 PM
0

HI,

Can you check if your RFC: SAP_PROXY_ESR is working fine in SM59?

Share
10 |10000 characters needed characters left characters exceeded
Avinash Ayanala Feb 27, 2017 at 12:41 PM
0

Hi Ratnakumar,

If the software component is created with the vendor name "sap.com" it will be not visible in sproxy. Once please check the vendor name. Hope this helps you .

If you are getting the error ICM_HTTP_CONNECTION_FAILED while going to "SXMB_ADM -->Integration Engine Configuration". then go to SICF--> choose hierarchy type(SERVICE)-->Client--> proxy settings--> uncheck the global proxy settings.

Regards,

Avinash

Share
10 |10000 characters needed characters left characters exceeded
ratnakumar injedu Feb 27, 2017 at 03:41 PM
0

Hi Avinash,

Thanks for the response.

The software component is created with the vendor name "sap.com".

I am not getting ICM_HTTP_CONNECTION_FAILED error while going to "SXMB_ADM -->Integration Engine Configuration. I also checked the proxy settings in SICF, the global proxy settings are uncheked.

Please suggest me what changes do I need to now to get the ESR objects seen in Sproxy.

Thanks and Regards,

Ratnakumar

Share
10 |10000 characters needed characters left characters exceeded
Avinash Ayanala Mar 01, 2017 at 02:28 PM
0

Hi Ratnakumar,

Try to create a software component with the vendor name other than sap.com. You should be able to see the software components in sproxy.
Do not use sap.com as vendor name while creating a software component in SLD.

Regards,

Avinash

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Avinash,

Thanks for the response. The issue got resolved already and I was able to find the objects in SPROXY.

Initially I created SCV with the vendor sap.com but later changed form sap.com to other name and it started working.

Thanks a lot for the response. I appreciate you time.

Thanks,

Ratnakumar

0