Skip to Content
0

Issue with SAP Query SQ01

Feb 23, 2017 at 12:13 PM

116

avatar image

Hello Experts,

I had made changes to an existing SAP Query to delete adjacent duplicates at the record processing. Now the selection screen was changed automatically ( see attached screenshots) which shows the differences in selection screen in development system and production system. Could you please help me in getting the actual selection screen which was in production as nothing was modified to the selection screen. ? Also I compared the basic structure in development and production and every thing is same for development and production . Kindly suggest.

Development system screen shot ( see highlighted)

Prod system

Thanks,

rg

dev-capture.png (10.2 kB)
prod-capture.png (8.7 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Jürgen L
Feb 23, 2017 at 12:32 PM
0

Please read OSS note 1940179 - Query selection screen changed after upgrade cannot select output format

It explains the design changes as well as what you have to do to get the old appearance back.

Show 4 Share
10 |10000 characters needed characters left characters exceeded

hello Jurgen,

Thanks very much for your reply.

But this note explains if an upgrade happened and if the selection screen was modified than it explains the steps to bring back the old selection screen.

In my case its a little different we are already at ECC7.4 version and the prod system shows the new selection screen and the dev system shows the old selection screen and more over for specific queries in dev it shows the new selection screen and for some others it shows old selection screen.

I tried giving the old selection screen as explained in the note and tried switching off the old selection screen but did not work.

please suggest .

rg

0

you probably have the old look in your development system because you never regenerated the query. But after transporting it is new generated in the prod system and got this way the new design.

You have to do your changes in your development system and then retransport your query.

0

Hi ,

is there a way that we can regenerate the query in development and get the new look same as in prod system.

thnks,

rg

0

Hello Jurgen,

I had regenerated the query with the old report structure unchecked and still its showing the old structure. Do I need to raise this to SAP as it is showing old structure .

Thanks,

rg

0
Raymond Giuseppi
Feb 23, 2017 at 12:37 PM
0

Are you comparing the selection-screen generated by SQ01 with the selection-screen generated by START_REPORT (e.g. when a transaction was designed to execute the query) with some variant?

Try to compare the same screen SQ01 or the created transaction in both system.

Show 3 Share
10 |10000 characters needed characters left characters exceeded

Hello Raymond,

The selection screen generated by SQ01 and START_REPORT are the same, but the issue is the selection screen generated in development and prod are different. I am looking for solution to make the dev system selection screen look like prod system sel screen. plz suggest

thanks,

rg

0

Settings:

In SQ02 menu, settings, deactivate the 'use the old report structure'.

Queries:

In SQ01 you can force for one query : extras, add. attributes, deactivate 'use of the old report structure'. In SQ02 you can also navigate Goto, Query Directory, mark all queries and click the generate button (will not be executed immediately, but at first execution of the query)

Regards,
Raymond

0

Hello Raymond,

Thanks for your reply. I already followed the steps mentioned but it didnt help.

Thanks,

rg

0