Skip to Content
0
Nov 19 at 12:01 AM

Crystal Reports Nuget 13.0.4001 generates an error

95 Views Last edit Nov 21 at 02:31 PM 2 rev

Our Visual studio project is a 64-bit website. We have been requiring the runtime installation to be installed for this website. We would like to include nuget packages to avoid installing the runtime.

I installed the CrystalReports.Engine nuget and 16 nuget/references are also applied including log4net v1.2.10. The project files reference "Include="log4net, Version=1.2.10.0, Culture=neutral, PublicKeyToken=1b44e1d426115821". This is a pretty old version of the log4net.

When I run our website and try to generate a report, I get the exception ""Could not load file or assembly 'log4net, Version=1.2.10.0, Culture=neutral, PublicKeyToken=692fbea5521e1304' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040...". It appears that the libraries are looking for the 32-bit version of log4net.

The nuget packages include 13.0.30.3805, not the latest 13.0.32 libraries. After doing some searching on-line, I am concerned that these nugets are not SAP generated nugets.

This leads me to a few questions:

  1. Are these SAP Crystal Reports nugets?
  2. How do they distinguish between 32-bit and 64-bit projects?
  3. Why are these nugets not using the latest version of the libraries.
  4. How do I resolve this error? (everything I have tried, doesn't fix the problem)