Skip to Content
Nov 07, 2022 at 11:43 AM

gCTS on SteamPunk, pulling by Commit ID does not work

284 Views Last edit Nov 07, 2022 at 01:54 PM 5 rev

Hi, we are using gCTS on SteamPunk(BTP ABAP Environment) and we have Dev and Qas environment. Pushing from Dev to remote repo and pulling them into Qas works if we are pulling all the released transport requests with 'Latest' option.

But we want to pull specific transport request to Qas. There is an 'Commit ID' option when pulling in Qas, which only pulls the specified Commit ID, which seems to serve this purpose. However, it only works if the commit ID of transport request specified is the earliest(oldest) on the timestamp.

To elaborate:

In Qas, press Pull and specify Commit ID(12345) of transport AAA. -> Only transport AAA is imported to Qas(Expected result).

In Qas, press Pull and specify Commit ID(67890) of transport BBB. -> Both AAA and BBB are imported to Qas(Unexpected result).

- Transport AAA, Commit ID 12345, pushed at 10:00:00 from Dev

- Transport BBB, Commit ID 67890, pushed at 11:00:00 from Dev

Is this the expected behavior? It seems that like all the transports that are older than the chosen Commit ID are imported, which I feel like is inconvenient and beats the purpose of this function.

I tried with both short and long commit ID, and using tag but it ended up in the same result.