Skip to Content
1

Unable to connect IOT MMS from SAP WebIDE

Feb 23, 2017 at 08:33 AM

160

avatar image
Former Member

Hi all,

I am getting 401(Unauthorized) error, while trying to call MMS functions (getData or postData) of IOT.js. I can successfully call RDMS functions(like getDevices, getMessageTypes, etc).

I have completed following tasks in my trial account.

1. Enabled IoT Service in HCP trial, deployed MMS and created devices/device types and message types.

2. Created two destinations, iotrdms with AppToAppSSO and iotmms with BasicAuthentication.

3. Added IOT.js file by selecting Inject IoT API library.

4. In my WebIDE project, I have added the two destinations(iotrdms and iotmms) in neo-app.json

5. Added code to call RDMS and MMS services.

Not sure, which configuration/setting I am missing.

Can you please help?

P.S. I sent a few messages from build-in HTTP API of IoT. It returned success code 200. I tried the same device endpoint URL from postman by adding OAuth 2.0 and my token(Bearer <token name>), but it gives 401 error in postman as well.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

avatar image
Former Member Mar 04, 2017 at 10:38 AM
1

Hi Swapnil,

I am also facing the same issue. Did you find the solution to the issue?

Can you please share the solution if you got it working.

Regards

Murthy

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Apr 25, 2017 at 09:49 AM
0

Hey Swapnil,

same Problem here.

Does it work now ? do u got any new Infos ?

Regards

Jan

Share
10 |10000 characters needed characters left characters exceeded