Skip to Content
0

Receiver ESR proxy objects not visible in SPROXY of ECC

Feb 23, 2017 at 07:28 AM

284

avatar image

Hi Experts,

Our scenario is SOAP to Proxy & our PI system is 7.31 dual stack where the receiver ESR objects are not visible in SPROXY of ECC [here ECC is S4HANA system]. Kindly suggest.

Thanks,

Ramu.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

avatar image
Former Member Feb 23, 2017 at 11:53 AM
0

Hi Ramu,

If you did not setup any PROXY connections between ECC anbd PI please follow the below link http://www.saptechnical.com/Tutorials/XI/Proxy/AAE.htm .

Thanks,

Avinash

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Thank you Avinash for sharing this!

0
avatar image
Former Member Feb 24, 2017 at 05:53 AM
0

1.Create 2 RFC Destinations of type T (TCP/IP) for the SLD connection – LCRSAPRFC and SAPSLDAPI in ECC. Provide the program IDs in both the destinations. For eg., LCRSAPRFC_SID/SAPSLDAPI_SID

2.Create a destination of type H (HTTP) in ECC [pointing to PI system]

3.In Transaction SXMB_ADM and goto ‘Integration engine configuration’. Select role of system as Application system and provide “dest:// ” under “Corresponding Integ. Server”. Here, refers to the destination that you created in step 2.

4.In the same window, click on ‘Specific configuration’ and under ‘Runtime’ Category and ‘IS_URL’ parameter, provide the same value that you gave above “dest:// ”

5.In PI, create the 2 RFC destinations of type T (LCRSAPRFC and SAPSLDAPI) and provide the same program ID that you gave in ECC.

Regards,

Vishal

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Vishal,

Thanks for your response! Now I can see the ESR objects in SPROXY. The issue is with user used in destination connecting to ESR. SLDCHECK also works fine. Currently facing the following issues:

1. When RZ70 is executed in ECC with the host details of PI the technical system is not getting created in PI SLD and RZ70 is not executed completely as shown below. In RZ10 the parameter gw/acl_mode is maintained as '0' .

How to resolve the above?

2. In SAPSLDAPI & LCRSAPRFC created in ECC I have given the "Gateway Host" & ""Gateway service" details of PI system and the program ID is maintained the same in both with that of T type destinations created in PI. But when I execute the connection test to both of them the below error is shown.

SLDCHECK works fine and SLDAPICUST are maintained well.

Please help to resolve.

Thanks,

Ramu.

rz70.jpg (60.7 kB)
sapsldapi.jpg (58.1 kB)
lcrsaprfc.jpg (57.9 kB)
0
Raghuraman S Feb 24, 2017 at 11:35 AM
0

Check if the below note helps.

1528587 - PI ESR Content Objects are not visible in SPROXY.

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Feb 24, 2017 at 02:27 PM
0

Sometimes this RFC shows red and will be good after the data is passed though it..!! The logic behind is program gets registered when called.. Give a try sending/recv data and check again..!!

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hello,

Thank you for your reply. But RZ70 execution is neither happening nor creating any technical system in PI SLD.

Regards,

Ramu.

0