Skip to Content
Aug 11, 2022 at 07:48 PM

Error related to log transfer for logical database


Dear Experts

We have WS pair managed by repserver1 now we are building MSA replication its source is the logical connection of WS and this MSA is managed by rep server2 , after we created route between them and make repserver1.rssd replicated , we tried to create replication definition as follow:

create database replication definition repdef 
with primary at LOGDS.LOGDB

where LOGDS is logical dataserver

and LOGDB is logical database

we got the following error:

Log transfer from 'LOGDS.LOGDB ' is OFF. Cannot create database replication definition for this database.

but when we issued at replication2.rssd database:


we got the result:

dsname dbname status
LOGDS LOGDB Log Transfer is ON,

rssd2 rssd2 Log Transfer is OFF, Distribution is ON

and at replication1.rssd database:

dsname dbname statu

LOGDS LOGDB Log Transfer is ON,
rssd2 rssd2 Log Transfer is ON, Distribution is ON

even that we tried to suspend log transfer to LOGDS.LOGDB then to resume it, but we got the error:

Log transfer status cannot be changed for logical connection LOGDS.LOGDB

any hint will be useful