Skip to Content
avatar image
Former Member

SMARTFORMS - set printer device

Hi,

I have a SMARTFORM which is always going to be output on the same printer regardless of who is printing it and their default printer.

I have seen a field on the form attributes for setting the output device - but it cannot be edited !

Any ideas ?

Cheers

Colin.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    May 18, 2006 at 10:32 AM

    Hi Colin,

    Set CONTROL_PARAMETER-NO_DIALOG = 'X'. and

    CONTROL_PARAMETERS-DEVICE = Printer_Name or

    OUTPUT_OPTIONS-TDPRINTER = Printer_name, it will always go to that pritner...

    Regds

    Sandip

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 18, 2006 at 10:21 AM

    Hai Colin

    CALL FUNCTION 'GET_PRINT_PARAMETERS'

    EXPORTING MODE = 'BATCH'

    REPORT = 'MYREPORT'

    IMPORTING OUT_PARAMETERS = PARAMS

    VALID = VALID.

    look into this link

    http://help.sap.com/saphelp_nw04/helpdata/en/d5/6243ea8a4111d4b605006094192fe3/content.htm

    You need to set the USER_SETTINGS perameter in your SmartForm to SPACE

    Thanks & regards

    Sreeni

    Add comment
    10|10000 characters needed characters exceeded

  • May 18, 2006 at 10:27 AM

    Hi,

    smartform fm ,you have options

    CONTROL_PARAMETERS you have DEvice field you can set that with your own device.

    and also USER_SETTINGS = ' '. if you don't want users default printer. if you want users printer then USER_SETTINGS = 'X'.

    try these..

    Regards

    vijay

    Add comment
    10|10000 characters needed characters exceeded