Skip to Content
0
Jun 30, 2022 at 06:30 PM

SAP BW - SQL Error: SQL0204 - /BI0/MTCTUSERNM in R3BIDDATA type *FILE not found.

94 Views Last edit Jun 30, 2022 at 06:49 PM 2 rev

Hi SAP BW community,

Error activating infoobject

SAP BW - SQL Error: SQL0204 - /BI0/MTCTUSERNM in R3BIDDATA type *FILE not found. (795101/BID Message no. DBMAN257

Have you seen this error before?

Cannot activate InfoObject 0TCTUSERNM in Development.

Objects exits/active/no issues in QA and Prod. Do not want to transport the object from QA to dev, company policy.

Need to fix in dev environment. How did this object become inactive, was there a patch upgrade for dev only, any change? No, there was no change. Not sure when it got deactivated.

There is an additional attribute - 0ORGUNIT that is causing issues clearly. This infoobject should not be attached as an attribute to 0TCTUSERNM. How did it get added as an attribute and when? I do not know, maybe a few years ago, before i joined this company.

Question: how to fix this?

Did the usual steps that we do, st22 - no short dumps, sm51, sm50, job monitor, nothing there, sm21 system logs, nothing there.

image.png

Here is the error on activation, obviously an error because it doesn't like the 0ORGUNIT attribute added as nav attribute to the 0TCTUSERNM infoobject.

image.png

Go to change mode, Extras --> Remove conversion lock

Activate, gives the same error, tried all that.

There is a SAP note to interpret the SQL error show, not sure how to look at it.

Tried installing it from business content, hoping it would overwrite the current infoobject, same error.

Have any of you seen this error? How did you resolve it?

Thanks!!

regards

Varun

Attachments

image.png (57.4 kB)
image.png (145.9 kB)