Skip to Content
0

No vora user in Vora1.3, but only in 1.2. Bug or not?

Feb 22, 2017 at 01:23 PM

71

avatar image
Former Member

I have followed this SAP tutorial (http://www.sap.com/developer/tutorials/vora-connect.html), with Vora 1.3 and everything seems to be working ok except that I cannot find vora user folder in file system.

I also tried with Vora 1.2, then everything was fine.

Will this cause any problems when using Vora 1.3?

10 |10000 characters needed characters left characters exceeded
Former Member

The file structure gives further evidence of the Vora 1.2 and Vora 1.3 difference...

Vora 1.3 seems to be lacking something

Vora 1.3:

Vora 1.2:

0
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Elitsa Milanova
Apr 27, 2017 at 01:41 PM
0

Hello,

The Vora 1.3 is based on Docker. This means that when you start an instance from CAL Vora 1.3 solution, you will get a docker container where the Vora 1.3 is running. In order to use "vora" user for example or if you need to run any specific to Vora requests you need to be inside the container. This is done when executing "docker exec -i -t <container_id> /bin/bash". From this point further you will be able to run whatever commands you need.

Kind regards,

Elitsa Milanova

Show 3 Share
10 |10000 characters needed characters left characters exceeded

One thing I forgot to mention - the tutorial you've checked is for Vora 1.3. There is a video link for Vora 1.3 which might be useful in this case: https://jam4.sapjam.com/blogs/show/LgfGOTf2GJgTURHiXBrTA9.

0
Former Member

Thank you, but I do not have access to the link you sent me. I have a SAP Jam account, but no access to the material you sent.

I tried your method, however, I do not know what my container_id is, so I cannot use it. I tried the long string in the filepath, but it was not that:

docker exec -i -t bc494061d0f919af6d509c5dd0b459cf6d769171da5de9ecf23a8d567d07239c /bin/bas

And I also found a file called id at /data/docker/devicemapper/mnt/bc494061d0f919af6d509c5dd0b459cf6d769171da5de9ecf23a8d567d07239c/, but the long string from here was not the correct id either.

0

Hi Morten. To check container-id execute command

docker ps
1