Skip to Content
1
Jun 10 at 10:06 AM

sap:filterable="false" properties appear on the Smart Filter Bar

265 Views Last edit Jun 20 at 07:48 AM 3 rev

Hi there,

I am facing an issue that non-filterable properties appear on the Smart Filter Bar on Fiori applications unless they are annotated as HiddenFilter="true" individually. Properties that have sap:filterable="false" in metadata shouldn’t be shown in the Smart Filter Bar and as far as I understand, this should be handled automatically by UI5. Is that correct? If so, could anyone advise me on how to apply it if there is a configuration in the manifest.json or elsewhere?

OData

Volume field (property name "Counter") has sap:filterable="false"

<EntityType Name="SampleType" sap:semantics="aggregate">
  <Key>
    <PropertyRef Name="GenId"/>
  </Key>
  <Property Name="Counter" Type="Edm.Decimal" Precision="18" Scale="0" sap:label="Volume" sap:aggregation-role="measure" sap:filterable="false"/>
  <Property Name="TrackingNumber" Type="Edm.String" MaxLength="255" sap:label="Tracking Number" sap:aggregation-role="dimension"/>
  <Property Name="TrackingStatus" Type="Edm.String" MaxLength="255" sap:label="Transit Status" sap:aggregation-role="dimension"/>
</EntityType>

Smart Filter Bar filter options in the App (Analytical List Page)

screenshot-2022-06-10-at-113713.png

I couldn’t find a similar issue in this forum and also documentation in the SDK, so any help would be much appreciated.

Thank you,

Ami

Attachments