Skip to Content
avatar image
Former Member

[RCIRAS0216] --- Error code:0 [CRWEB00000119]

Hi all,

We are recently facing a strange problem regarding Crystal reports.

When going to the History in CMC and checking the instances, we are getting the below error.

The viewer could not process an event.Internal error. Please contact your system administrator. [RCIRAS0216] --- Error code:0 [CRWEB00000119]

Now the strange part is first time we are getting this error, but second time after clicking we are not getting this error. If we then log out and try to view the same instance they get the error message again. We do see the instance the drill down report works.

We are using SAP CR 2013.

In Windows event viewer log we got another error beside the error mentioned above.

There is no server available, to process your request. Please try it later once again or ask your System administrator, if the problem persists. [RCIRAS0387]

I have found several suggestions in this forum, but not actually finding related to the instances.

https://archive.sap.com/discussions/thread/3865518

Any help is much appreciated.

Thanks, Sudam

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    Feb 23, 2017 at 04:27 PM

    The box having SQL Express and SQL Anywhere should not be affecting this. I suggest you to open an incident with SAP Support under BI-BIP-ADM component.

    Thanks,

    Megh

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 22, 2017 at 08:09 PM

    Looks like some kind of corruption.

    Do you get this error on all the reports or only Drilldown report.

    If only drilldown then how many instances are there for this report.

    Did you try restarting all the CR Services and then check?

    Since when are you observing this issue? Any changes made?

    Regards,

    Megh

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 23, 2017 at 08:54 AM

    Hi Megh,

    The problem is only with drilldown reports, not with all the reports. We tried to add a new instance today for a new user and got a failed instance. I could see the data but when I clicked to view the subreport I was asked for the database password. I checked a couple of the instances that had been migrated from our old system and for these the subreports ran without asking for the password. The DB configuration is set as "Use same Database Logon as when report is run". we have restarted all the CR services and no changes were made.

    Another thing I have noticed. The box was originally built with SQL Express installed on it. This is still on the server – could this be affecting/interfering with SQL Anywhere which is our default CMS DB?

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 19, 2017 at 08:01 AM

    Hi,

    The issue is finally resolved by deleting the CR2013 Processing server and CR Caching server from the data folder, which after restart of SIA got recreated and the error message is disappeared. But still I am confused why our Database configuration tab is not showing the custom database logon information option in spite of being logged on as Administrator. It is only showing the " Using original data source"

    Regards,

    Sudam

    Add comment
    10|10000 characters needed characters exceeded

    • What is the Data source and the middleware of the report having this issue?

      Does this happen with a particular report or all the crystal reports?

      Thanks,
      ~Megh