Skip to Content
3
Apr 22 at 02:46 AM

Qunit Coverage not working with ES6+ syntax

405 Views

Hello Team,

We have been using Qunits for testing our controller code on our fiori applications and we have been using ES6+ syntax. The unit tests do work fine and give you the results however when I enable the coverage using the on the qunit runner html page then it errors out at specifc points where a ES6+ syntax had been used.

It seems to be like the library sap.ui.qunit.qunit-coverage doesnt likes the es6+ syntax. Anyone else facing similar issue and have found a solutiuon around? the alternative we have been doing till now is to convert the code below es6 because we tested it and it works but would like to avoid doing that for obvious reasons.

Regards,

Manish