Skip to Content
avatar image
Former Member

Dispatcher running but no server connected: J2EE Engine stopped

Hi,

When I try to start the XI Home page I am getting the following error: <b>"Dispatcher running but no server connected!"</b>.

In the defaultTrace.trc file I see the following entry:

<b>Service com.sap.security.core.ume.service error. Nested exception is: com.sap.engine.frame.ServiceException: User SAPJSF has no RFC authorization for function group SYST .</b>

<b>...Critical shutdown was invoked. Reason is: Core service com.sap.security.core.ume.service failed. J2EE Engine cannot be started.#</b>

I am unable to connect to Visula Administrator.

Can any one let me know how to slove this problem.

The whole SAP NetWeaver stack is down.

Thanks in advance,

Nagarjuna.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

6 Answers

  • Best Answer
    May 16, 2006 at 06:57 AM

    Hi Nagarjuna,

    after generating you need to update the authorizations to the assigned user SAPJSF. You do so in transaction PFCG. Again, choose role SAP_BC_JSF_COMMUNICATION_ROLE, change to tab rider "User". To do so, choose "User comparison" and complete the cmoparison.

    Kind regards

    Dirk

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 15, 2006 at 10:39 PM

    You're using an ABAP backend system as your UME. The RFC user that connects the Java stack to the ABAP stack is SAPJSF. That user doesn't have the correct authorizations.

    Have your security team add or modify the S_RFC authorization object in the user profile for SAPJSF to include the SYST function group.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Carlos,

      There is no other team here. We are everything.

      I am not sure about the modification of S_RFC authorization.

      In SU01(Client #000)-> for SAPJSF user there are only 2 roles assigned SAP_J2EE_GUEST & SAP_BC_JSF_COMMUNICATION.

      No Profiles assigned to SAPJSF user.

      If you have any idea regarding this, please guide me. I'll do the required modifications.

      Thanks,

      Nagarjuna.

  • May 16, 2006 at 06:14 AM

    Hi Nagarjuna,

    SAP_BC_JSF_COMMUNICATION is the role to change. Start transaction PFCG, edit that role, jump to the tab rider "authorizations" and change the authorization data.

    In that tree expand the subtree "Cross-application Authorization Objects --> Authorization Check for RFC Access". Here you can add the necessary authorization to execute function group SYST.

    And, after changing the authorizations, don't forget to generate a profile for the changed role by choosing the "Generate" button.

    Hope that helps

    Dirk

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Dirk Jenrich,

      I am arpan saini. when i am try to connect to portal //10.10.1.68:50000/irj/portal

      this url , using stsndard user id J2ee_admin

      as you suggest Mr. Parsant i complete all step and generat profile and add in SAPJSF user and administrator id also.

      after login when i click on menu buton then error throw "dispatcher is running but server is stopped."

      please resolve my problem ASAP

      thanks & Regards

      Arpan Saini

  • avatar image
    Former Member
    May 15, 2006 at 10:49 AM

    Maha,

    This means that you XI server is not functioning properly. If you have acecss to your server, check to make sure that all the instances are of 'green' color - there are three nodes: server, dispatcher, and the IGS Watchdog. All of these should be green and the services associated with them should also be running.

    Please check and try again.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      I am unable to access, any thing under SAP NetWeaver stack.

      All the below are giving the same error:

      http://locahost:50100

      http://locahost:50100/nwa

      http://locahost:50100/rep/start/index.jsp (XI home page)

      http://locahost:50100/sld

      <b>Error: Dispatcher running but no server connected!</b>Thanks,

      Nagarjuna.

  • avatar image
    Former Member
    Feb 21, 2008 at 11:33 PM

    Hello Arpan,

    Can you paste an excerpt from std_server0.out file which mentions the exception related to startup of the server process ?

    Dispatcher/But no server is a generic error message. It means the server process is not up. Which could be due to various reasons.

    Regards,

    Snehal

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 20, 2009 at 06:22 PM

    We had a similar problem on the AIX platform.

    It was caused by a large interface file which an XI channel was trying to process, so every time we started the Java stack we got heapdump and javacore files in /usr/sap/<SID>/DVEBMGS00/j2ee/cluster/server0

    The javacore files gave us details of the Sender Agreement (SA) which was problematic, which led us to the file that was causing the problem. The problem was resolved by renaming the file, stopping both java and abap stacks via stopsap, running cleanipc <abap instance number> remove and cleanipc <java instance number> remove, checking ipcs to see that everything was clean before running startsap.

    Add comment
    10|10000 characters needed characters exceeded