Skip to Content
avatar image
Former Member

NW 2004s+MI

hi all,

Has anyone tried Mobile Infrastructure on NetWeaver 2004s?

if so, can you let me know how to setup the middleware for MI? Is there any post-installation configuration like what we do in WebAS640?

Regards

Ak.

PS: Useful answers will be appropriately rewarded [:)]

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    May 15, 2006 at 04:02 PM

    hello arun,

    nw04s installation asks you for a usage type (PI, EP, DI, MI)

    etc during the setup. after the installation you will only

    have to run the configuration template:

    "MI Post Installation Process"

    using the Template Installer. the same functionality is

    already available from 04 SP16... it will save you some

    time and energy by using this configuration template.

    refer to the NWA documentation for details on the template

    and template installer.

    regards

    jo

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Jacco,

      "Could not connect to middleware" error comes when the ABAP stack is not responding with data. Please check the following points:

      1. Your ABAP stack should be up and running.

      2. The JCo JRA connection is configured properly. You can check this in Visual Administration tool. The password should be correct. The host name, client etc everything should be correct. If everything is correct change the password for the user in ABAP stack, choose a password with all letters uppercase, change it in visual admin also and then restart the J2EE Engine.

      3. In the ABAP system check the number of connections open. If there are too many RFC connections open even then this problem occurs.

      This should solve your problem.

      Regards,

      Parminder

  • avatar image
    Former Member
    Jan 19, 2007 at 10:39 PM

    Hi Ak,

    Have you ever checked if the user you are using to connect to the middleware when starting Post Installation script has access to create users (su01), create RFC destination (sm59).. and so on? I suggest you try using SAP_ALL, SAP_NEW, just for testing.

    Anyway, if you cannot do this, create by your self. Use step-by-step scritp instead of full script, maybe its missing some service users or passwords are not correct.

    I dont remember right now what I have done, but I used step-by-step scripts instead of full scritp and it worked propertly.

    I hope I could help.

    Regards,

    Rogério

    Add comment
    10|10000 characters needed characters exceeded