Skip to Content
Feb 11, 2022 at 01:43 PM

SAP Business One v10 FP 2108 for HANA TransactionNotification


I'm trying to upgrade some databases from SAP v9.3 PL12 to SAP v10 FP2108.

I was able to upgrade some small new databases but ran into a problem with one of the bigger and older ones.

The problem is that TransactionNotification returns a problem:


It doesn't matter what object I'm updating (OUSR, ORDR etc.). The error is always the same.

Some of validations are done directly in TransactionNotification, other are started using CALL "anotherprocedure".

After a few tests:

If I use TransactionNotification from 9.3 version - I have this error.

If I use empty TransactionNotification - everything is ok

If I use TransactionNotification without some last added validation (that are started via CALL command) - everything is ok

If I use TransactionNotification with some last added validation but moved directly to TransactionProcedure - everything is ok

I analyzed these Stored Procedures that are referenced from Transaction Notification and I don't see a problem with a structure but probably with table OCRD (BP table).

If I run below stored procedure directly from HANA studio (it's only example)- it works.image.png

But when I use it from Transaction Notification (I tested it as the only one validation in TN) - I have this error.


That's strange but everything has worked in 9.3. The problem doesn't exists if I change OCRD to OITM or other table

It looks like some kind of permission problem on database that was migrated to v10.

Has anyone encountered such a problem or has an idea how to further analyze it?


image.png (11.6 kB)
image.png (11.1 kB)
image.png (9.4 kB)