Skip to Content
1
Jan 24 at 12:16 PM

ABAP communication layer is not configured properly. (M1 Mac)

875 Views

Hi All,

I have installed Eclipse on my M1 chip MacBook Pro but it does not working properly. I installed Java. After that I installed Eclipse. I cannot use Eclipse properly, I cannot connect any system.

You can see java version as below

ahmeterturk@Ahmet-MacBook-Pro ~ % java --version
openjdk 17.0.1 2021-10-19
OpenJDK Runtime Environment Homebrew (build 17.0.1+1)
OpenJDK 64-Bit Server VM Homebrew (build 17.0.1+1, mixed mode, sharing)

The Error(Also, I attached screenshot):

ABAP communication layer is not configured properly. Consult the installation guide or download page for further details.

JCo initialization failed with java.lang.UnsatisfiedLinkError: no sapjco3 in java.library.path: /Users/ahmeterturk/Library/Java/Extensions:/Library/Java/Extensions:/Network/Library/Java/Extensions:/System/Library/Java/Extensions:/usr/lib/java:.

My system info:

  • MacBook Pro M1 Chip
  • Eclipse IDE for Java Developers (includes Incubating components)
    Version: 2021-12 (4.22.0) Build id: 20211202-1639

How can I solve that issue?

Thanks in advance

eclipse-error.png

Attachments

eclipse-error.png (374.0 kB)