Skip to Content
0
Dec 31, 2021 at 11:29 PM

ASE/SYSAM thinks hostid is null [KBAs 2993255 / 2422577 ?]

235 Views Last edit Jan 01, 2022 at 08:01 PM 11 rev

I'm in the process of replacing a VM (old=SUSE 11 / new=Ubuntu 20.04).

I've been able to get all but one of my SAP/Sybase software installations migrated successfully:

ASE 15.7 SP140                       # failure (more below)
ASE 16.0 SP03 PL07                   # success
RS 15.7.1 SP306                      # success
RS 16.0 SP03 PL07                    # success
Data Assurance 16.0 SP03 PL06        # success
SYSAM_2_4                            # success

The ASE 15.7 software installation completes successfully and I can successfully create a new ASE instance. There's just one issue, ASE's SYSAM component thinks the hostid is null (see last line from this errorlog snippet):

00:0000:00000:00000:2021/12/31 15:44:03.03 kernel  SySAM:  The hostid of this system does not match the hostid
00:0000:00000:00000:2021/12/31 15:44:03.03 kernel  SySAM:  specified in the license file.
00:0000:00000:00000:2021/12/31 15:44:03.03 kernel  SySAM: License feature name:  ASE_CORE
00:0000:00000:00000:2021/12/31 15:44:03.03 kernel  SySAM: License hostid:        000011223344
00:0000:00000:00000:2021/12/31 15:44:03.03 kernel  SySAM: License search path:   /opt/sybase/ASE_157_SP140/SYSAM-2_0/licenses/ASE.EV.lic:
00:0000:00000:00000:2021/12/31 15:44:03.03 kernel  SySAM: FLEXnet Licensing error:-9,57.  System Error: 19 "(null)" 

NOTES:

  • all ASE/SRS/DA instances (other than the ASE 15.7 instance) are able to successfully check out the associated EV licenses (mix of served and unserved)
  • the ASE 15.7 and ASE 16.0 instances are using the same EV license
  • for the ASE 15.7 instance I get hostid=null for both served and unserved license
  • for the ASE 15.7 instance there are no problems if using the XE or DE license file, but this is expected since those license files are coded for ANYHOST (and hostid=null qualifies as 'ANYHOST')
  • I've successfully installed the i386 architecture and associated libs (into Ubuntu 20.04) and verified 32-bit apps do work in this 64-bit VM

I've also verified this behavior (hostid=null) with the associated SYSAM/cpuinfo:

sybase:/opt/sybase/ASE_157_SP140/SYSAM-2_0/bin
$ ./cpuinfo
License hostid:                                          <<<=== no hostid is displayed 
Detected 4 logical processor(s), 4 core(s), in 2 chip(s)

The RS 15.7.1 version of SYSAM/cpuinfo, running on the same VM, does show the hostid:

sybase:/opt/sybase/RS_1571_SP306/SYSAM-2_0/bin
$ ./cpuinfo
License hostid:        000011223344                     <<<=== correct hostid displayed
Detected 4 logical processor(s), 4 core(s), in 2 chip(s)

KBA 2993255 looks like a possible match (ASE 15.0, invalid host, hostid = ' null').

KBA 2422577 looks like a match for the `cpuinfo` program generating hostid=null.

Question: Could someone with access to KBAs 2993255 and 2422577 respond with the resolutions to these issues?

Thanks,

Mark