Skip to Content

getting error while resetting sap* password

Dear Experts,

we need to resetting sap* password of solution manager. but while resetting its password.

not getting sap* entry in schema. please find below cmd out put. from other user i cannot login due to license expiry error.

SQL> select UFLAG, BNAME, MANDT from SAPSR3.USR02 where BNAME='SAP*';

no rows selected

For DDIC getting right output

SQL> select UFLAG, BNAME, MANDT from SAPSR3.USR02 where BNAME='DDIC'; UFLAG BNAME MANDT ---------- ------------------------------------ --------- 0 DDIC 001

kindly suggest.

Thanks in advance

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Feb 21, 2017 at 06:51 PM

    Hi Mohsin,

    SAP* is created by Kernel without any user master record that is the reason it is not showing in USR02 table which is standard.

    Just change below parameter value to "0" and restart SAP instance so that it allows you to login using SAP*/PASS.

    login/no_automatic_user_sapstar

    If you want to have your own password of SAP*, then reset it and make sure you create SAP* from SU01 so that entry gets created in USR02 and then you can use your own password.

    Regards,

    Harish Karra

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 21, 2017 at 01:36 PM

    Hi,

    How did you reset password?

    Regards,

    Nagarajan

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 22, 2017 at 06:41 AM

    Dear Experts,

    i am trying to reset by below method. but problem still exist. system not resetting its password even after changing parameter.

    1. Remote Desktop (Windows) / Telnet (Unix/Linux) to OS level and connect to the sql using the command prompt.

    C:\Documents and Settings\devadm>sqlplus"/as sysdba"

    2. View the SAP* table.

    SQL> select UFLAG, BNAME, MANDT from SAPSR3.USR02 where BNAME='SAP*';

    3. Unlock the SAP* password.

    SQL> update SAPSR3.USR02 set UFLAG=0 where BNAME='SAP*' and MANDT=000;

    4. Reset the SAP* password

    SQL>delete from SAPSR3.USR02 where BNAME='SAP*' and MANDT=000;

    5. Set the parameter login/no_automatic_user_sapstar is set to 0. You also can check in RZ11. You need to reboot the SAP once the parameter is change.

    login/no_automatic_user_sapstar=0


    kindly suggest
    Thanks
    Add comment
    10|10000 characters needed characters exceeded