Skip to Content
avatar image
Former Member

InfoSpoke using BADI

Hello Gurus,

I have a InfoSpoke with ODS as Data Source,Extraction Mode is Full. It generates file on application server. The transformation uses BADi. The InfoSpoke is active and used in production.

We want to put some selection criteria on some InfoObjects. When I try to do that in dev box, it dumps with message type X.

It is not allowing to make any changes in the Selection tab.

Any reason that this is happeneing?

Please advice.

Thanks

Simmi

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    May 11, 2006 at 07:22 PM

    Please take a look at the input generated by the activation of infospoke after the selection have been made on info objects. If the input structure order has changed the BADI would not be correct or it might have become inactive. So see that the input and ouput structure is active, look at the BADI look for the class on the BADI if its active and then look at the ABAP code in the BADI if the recent version is active.

    Just an insight and direction to debug your issue.

    Thanks

    Nag

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 11, 2006 at 10:18 PM

    Praveen,

    Thanks for the reply. But, when I was unchecking the BADI, the system did not prompt for deactivation of BADI class.

    when you say the BADI would have errored out, how dod i check it. Because when I go to it in SE19, I find the class and the implementation active.

    Simmi

    Add comment
    10|10000 characters needed characters exceeded