Skip to Content
Nov 04, 2021 at 04:04 PM

Update to CDS 5.6.1 - dumps cds run



I was having some issues with CQL and where statements and I noticed I was running in a slightly older version - 5.5.1 - so I decided to upgrade to the latest version 5.6.1.

Welcome in a world of pain ... when I run 'cds run' I am getting the following nice dump:

[INTERNAL ERROR] TypeError: Cannot read property 'items' of undefined
    at checkKeySpecViolations (/node_modules/@sap/cds-compiler/lib/edm/edmPreprocessor.js:1403:56)
    at /node_modules/@sap/cds-compiler/lib/edm/edmPreprocessor.js:1328:11
    at /node_modules/@sap/cds-compiler/lib/edm/edmUtils.js:67:11
    at Array.forEach (<anonymous>)
    at foreach (/node_modules/@sap/cds-compiler/lib/edm/edmUtils.js:62:44)
    at initializeEdmKeyRefPaths (/node_modules/@sap/cds-compiler/lib/edm/edmPreprocessor.js:1311:7)
    at /node_modules/@sap/cds-compiler/lib/model/csnUtils.js:690:30
    at Array.forEach (<anonymous>)
    at cb (/node_modules/@sap/cds-compiler/lib/model/csnUtils.js:690:16)
    at forEachGeneric (/node_modules/@sap/cds-compiler/lib/model/csnUtils.js:686:5)

With the debugger I think I pinpointed it to the following entity which is causing this dump

entity AnalyticsConversationsMonths as select from AnalyticsConversationsDateBase {
  key period,
  sum(conversations) as conversations,
  sum(users) as users
} group by period
  order by period desc;

This all worked nicely ofcourse in the previous version.

Anybody having any suggestions ?