Skip to Content
0

Autocomplete not working in SAPUI5 for Eclipse Neon

Feb 21, 2017 at 05:27 AM

883

avatar image

I cannot get autocomplete to work for SAPUI5 application in Eclipse Neon. For the project properties and then Project Facets, SAPUI5 Application checkbox has been selected and the version shows latest.

I have looked at the article https://help.sap.com/saphelp_nw74/helpdata/en/85/ce1edb55dd4de3beac5b6d24d36d8a/content.htm but this does not seem to work.

Any help to resolve this is appreciated.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Jay Malla Feb 21, 2017 at 05:43 AM
0

I did also see this article - https://archive.sap.com/discussions/thread/3695108

which points to https://bugs.eclipse.org/bugs/show_bug.cgi?id=507782 - that shows there is an issue with code completion in Neon.

Is anyone else running into this issue? Has anyone gotten this to work in Eclipse Neon?

Share
10 |10000 characters needed characters left characters exceeded
Jay Malla Feb 21, 2017 at 06:11 AM
0

I installed Eclipse Mars and it is working just fine. So it seems to be an issue with Eclipse Neon. Any one got autocomplete working with Eclipse Neon for javascript?

Share
10 |10000 characters needed characters left characters exceeded
Samuele Barzaghi Sep 10, 2017 at 02:26 PM
0

Same problem.

Up to now JSDT 2.0 (it means eclipse neon and oxygen) is missing the content outline and content proposal functionality:

https://wiki.eclipse.org/JSDT/JSDT_Code_Analytics

Need help:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=504057

Share
10 |10000 characters needed characters left characters exceeded