Skip to Content
1
3 days ago

OAuth Client Grant Error – User authentication failed: PASSWORD_CHANGE_REQUIRED

77 Views Last edit 2 days ago 2 rev

Hi there,

We are running our application on Cloud Foundry Cloud. Our Java application is binding with org.cloudfoundry.managed-service xsuaa. Everything worked fine for months until last Saturday our application crashed by error:

org.cloudfoundry.uaa.UaaException: unauthorized: {"error":"invalid_grant","error_description":"User authentication failed: PASSWORD_CHANGE_REQUIRED"}	at org.cloudfoundry.reactor.util.ErrorPayloadMappers.lambda$null$8(ErrorPayloadMappers.java:89)	Suppressed: reactor.core.publisher.FluxOnAssembly$OnAssemblyException: 
Assembly trace from producer [reactor.core.publisher.MonoCacheTime] :
	reactor.core.publisher.Mono.checkpoint(Mono.java:1879)
	org.cloudfoundry.reactor.tokenprovider.AbstractUaaTokenProvider.token(AbstractUaaTokenProvider.java:255)
Error has been observed at the following site(s):
	|_ Mono.checkpoint ⇢ at org.cloudfoundry.reactor.tokenprovider.AbstractUaaTokenProvider.token(AbstractUaaTokenProvider.java:255)
	|_ Mono.checkpoint ⇢ at org.cloudfoundry.reactor.client.v2.info.ReactorInfo.get(ReactorInfo.java:49)
	|_____ Mono.checkpoint ⇢ at org.cloudfoundry.reactor.tokenprovider.AbstractUaaTokenProvider.token(AbstractUaaTokenProvider.java:255)
	|_ Mono.checkpoint ⇢ at org.cloudfoundry.reactor.client.v2.organizations.ReactorOrganizations.list(ReactorOrganizations.java:202)
	|_ Flux.checkpoint ⇢ at org.cloudfoundry.operations.applications.DefaultApplications.list(DefaultApplications.java:330)
	|_ Flux.checkpoint ⇢ at org.cloudfoundry.operations.applications.DefaultApplications.list(DefaultApplications.java:330

I don't get what "User authentication failed: PASSWORD_CHANGE_REQUIRED" means. So I tried reset Communication User password in SAP GUI, but it doesn't work. This error is not threw by user login but when deployment. So our application can't start and run.

I'm wondering what PASSWORD_CHANGE_REQUIRED indicates and hot to fix this? Thanks!